net-proxy/shadowsocks-rust: stabilize 1.16.1 for amd64, arm64
[gentoo-zh.git] / sci-libs / libticonv / libticonv-9999.ebuild
blob0afc4a8b46d71430a182a22d1e2fb6aab27302c6
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit autotools git-r3
8 DESCRIPTION="Charset conversion library for TI calculators"
9 HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
10 SRC_URI=""
12 EGIT_REPO_URI="https://github.com/debrouxl/tilibs.git"
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS=""
17 IUSE="doc iconv static-libs"
19 RDEPEND="dev-libs/glib:2"
20 DEPEND="${RDEPEND}
21 virtual/pkgconfig"
23 DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
25 src_prepare() {
26 S="${S}/${PN}/trunk/"
27 cd "${S}"
29 eautoreconf
32 src_configure() {
33 econf \
34 $(use_enable iconv) \
35 $(use_enable static-libs static)
38 src_install() {
39 default
40 if use doc; then
41 dohtml docs/html/*
42 docinto charsets
43 dohtml docs/charsets/*