1 # Copyright 2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit meson ninja-utils git-r3
8 EGIT_REPO_URI
="https://github.com/Genymobile/scrcpy.git"
10 if [[ ${PV} = 9999* ]]; then
18 MY_SERVER_PN
="scrcpy-server"
19 MY_SERVER_P
="${MY_SERVER_PN}-v${MY_SERVER_PV}"
21 SRC_URI
="https://github.com/Genymobile/${PN}/releases/download/v${MY_SERVER_PV}/${MY_SERVER_P}"
23 DESCRIPTION
="Display and control your Android device"
24 HOMEPAGE
="https://blog.rom1v.com/2018/03/introducing-scrcpy/"
36 DEPEND
="${COMMON_DEPEND}"
37 RDEPEND
="${COMMON_DEPEND}"
43 -Dprebuilt_server="${DISTDIR}/${MY_SERVER_P}"