sys-libs/elog-functions: add EAPI=8
[gentoo-zh.git] / app-mobilephone / scrcpy / scrcpy-1.23.ebuild
blob1de4dcb81c9930eb4c201860ee048087cc6d616d
1 # Copyright 2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit meson ninja-utils git-r3
8 EGIT_REPO_URI="https://github.com/Genymobile/scrcpy.git"
10 if [[ ${PV} = 9999* ]]; then
11 MY_SERVER_PV="1.3"
12 else
13 EGIT_COMMIT="v${PV}"
14 MY_SERVER_PV="${PV}"
15 KEYWORDS="~amd64"
18 MY_SERVER_PN="scrcpy-server"
19 MY_SERVER_P="${MY_SERVER_PN}-v${MY_SERVER_PV}"
21 SRC_URI="https://github.com/Genymobile/${PN}/releases/download/v${MY_SERVER_PV}/${MY_SERVER_P}"
23 DESCRIPTION="Display and control your Android device"
24 HOMEPAGE="https://blog.rom1v.com/2018/03/introducing-scrcpy/"
26 LICENSE="Apache-2.0"
27 SLOT="0"
28 IUSE=""
30 RESTRICT="test"
32 COMMON_DEPEND="
33 virtual/libusb:1
34 media-libs/libsdl2
35 media-video/ffmpeg"
36 DEPEND="${COMMON_DEPEND}"
37 RDEPEND="${COMMON_DEPEND}"
38 PDEPEND=""
40 src_configure() {
41 local emesonargs=(
42 -Db_lto=true
43 -Dprebuilt_server="${DISTDIR}/${MY_SERVER_P}"
45 meson_src_configure