1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 VALA_MIN_API_VERSION
="0.34"
7 VALA_USE_DEPEND
="vapigen"
9 inherit autotools gnome2-utils vala
11 DESCRIPTION
="LightDM greeter forked from Unity by Linux Mint team"
12 HOMEPAGE
="https://github.com/linuxmint/slick-greeter"
14 if [[ ${PV} == 9999 ]];then
18 EGIT_REPO_URI
="${HOMEPAGE}"
20 SRC_URI
="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
21 KEYWORDS
="~x86 ~amd64"
22 S
="${WORKDIR}/${PN//lightdm-}-${PV}"
31 >=x11-misc/lightdm-1.12[introspection,vala]
32 >=dev-util/intltool-0.35.0
38 >=x11-libs/gtk+-3.20:3
39 media-libs/libcanberra
46 export VALAC
="$(type -P valac-$(vala_best_api_version))"
53 doins
"${FILESDIR}/${PN//lightdm-}.conf"
57 gnome2_schemas_savelist
62 einfo
"To enable the slick-greeter support, set the greeter-session option"
63 einfo
"to 'slick-greeter' in your lightdm.conf in order to get this:"
64 einfo
"greeter-session=slick-greeter"
65 einfo
"then, restart your session and the lightdm/xdm daemon."