app-editors/visual-studio-code-bin: make repoman happy (#997)
[gentoo-zh.git] / app-i18n / fcitx5-chinese-addons / fcitx5-chinese-addons-5.0.6-r1.ebuild
blobf27dea155a47e03920820574ed3a658669bb63dd
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit cmake gnome2-utils xdg git-r3
7 EGIT_REPO_URI="https://github.com/fcitx/fcitx5-chinese-addons.git"
9 if [[ "${PV}" == 9999 ]]; then
10 KEYWORDS=""
11 else
12 KEYWORDS="~amd64 ~x86"
13 EGIT_COMMIT="${PV}"
16 SRC_URI="https://download.fcitx-im.org/data/py_stroke-20121124.tar.gz -> fcitx-data-py_stroke-20121124.tar.gz
17 https://download.fcitx-im.org/data/py_table-20121124.tar.gz -> fcitx-data-py_table-20121124.tar.gz
20 DESCRIPTION="Addons related to Chinese, including IME previous bundled inside fcitx4."
21 HOMEPAGE="https://github.com/fcitx/fcitx5-chinese-addons"
23 LICENSE="BSD-1 GPL-2+ LGPL-2+ MIT"
24 SLOT="5"
25 IUSE="+opencc +gui browser test"
26 REQUIRED_USE=""
28 RDEPEND="app-i18n/fcitx5
29 app-i18n/libime
30 opencc? ( app-i18n/opencc:= )
31 gui? (
32 dev-qt/qtcore:5
33 dev-qt/qtdbus:5
34 dev-qt/qtconcurrent:5
35 app-i18n/fcitx5-qt[qt5,-only_plugin]
36 browser? (
37 dev-qt/qtwebengine:5
40 DEPEND="${RDEPEND}
41 kde-frameworks/extra-cmake-modules:5
42 virtual/pkgconfig"
44 src_prepare() {
45 ln -s "${DISTDIR}/fcitx-data-py_stroke-20121124.tar.gz" modules/pinyinhelper/py_stroke-20121124.tar.gz || die
46 ln -s "${DISTDIR}/fcitx-data-py_table-20121124.tar.gz" modules/pinyinhelper/py_table-20121124.tar.gz || die
47 cmake_src_prepare
48 xdg_environment_reset
51 src_configure() {
52 local mycmakeargs=(
53 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
54 -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
55 -DENABLE_GUI=$(usex gui)
56 -DENABLE_OPENCC=$(usex opencc)
57 -DENABLE_BROWSER=$(usex browser)
58 -DUSE_WEBKIT=no
60 cmake_src_configure
63 src_install(){
64 cmake_src_install