1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit cmake gnome2-utils xdg git-r3
7 EGIT_REPO_URI
="https://github.com/fcitx/fcitx5-chinese-addons.git"
9 if [[ "${PV}" == 9999 ]]; then
12 KEYWORDS
="~amd64 ~x86"
16 SRC_URI
="https://download.fcitx-im.org/data/py_stroke-20121124.tar.gz -> fcitx-data-py_stroke-20121124.tar.gz
17 https://download.fcitx-im.org/data/py_table-20121124.tar.gz -> fcitx-data-py_table-20121124.tar.gz
20 DESCRIPTION
="Addons related to Chinese, including IME previous bundled inside fcitx4."
21 HOMEPAGE
="https://github.com/fcitx/fcitx5-chinese-addons"
23 LICENSE
="BSD-1 GPL-2+ LGPL-2+ MIT"
25 IUSE
="+opencc +gui browser test"
28 RDEPEND
="app-i18n/fcitx5
30 opencc? ( app-i18n/opencc:= )
35 app-i18n/fcitx5-qt[qt5,-only_plugin]
41 kde-frameworks/extra-cmake-modules:5
45 ln -s "${DISTDIR}/fcitx-data-py_stroke-20121124.tar.gz" modules
/pinyinhelper
/py_stroke-20121124.
tar.gz || die
46 ln -s "${DISTDIR}/fcitx-data-py_table-20121124.tar.gz" modules
/pinyinhelper
/py_table-20121124.
tar.gz || die
53 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
54 -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
55 -DENABLE_GUI=$
(usex gui
)
56 -DENABLE_OPENCC=$
(usex opencc
)
57 -DENABLE_BROWSER=$
(usex browser
)