1 # Copyright 2017-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
7 if [[ ${PV} == 9999* ]] ; then
9 EGIT_REPO_URI
="https://github.com/zchunk/zchunk.git"
10 EGIT_CHECKOUT_DIR
=${PN}-${PV}
12 SRC_URI
="https://github.com/zchunk/zchunk/archive/refs/tags/${PV}.tar.gz -> ${PN}-${PV}.tar.gz"
13 KEYWORDS
="~amd64 ~riscv"
14 S
="${WORKDIR}/${PN}-${PV}"
17 DESCRIPTION
="A format designed for highly efficient deltas while maintaining good compression"
18 HOMEPAGE
="https://github.com/zchunk/zchunk"
21 IUSE
="doc +curl +openssl test +zstd"
22 RESTRICT
="!test? ( test )"
25 curl? ( net-misc/curl )
26 openssl? ( dev-libs/openssl:0/3 )
27 zstd? ( app-arch/zstd )
34 $
(meson_feature curl with-curl
)
36 $
(meson_feature openssl with-openssl
)
37 $
(meson_feature zstd with-zstd
)
38 $
(meson_use
test tests
)