dev-python/conda-libmamba-solver: bump version to 24.11.1
[gentoo-zh.git] / app-editors / typora / typora-0.11.18.ebuild
blob4fb1b5605759d54d060e6ed96b73338c6cc6a705
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit desktop unpacker xdg
8 DESCRIPTION="Typora will give you a seamless experience as both a reader and a writer."
9 HOMEPAGE="https://typora.io"
10 SRC_URI="https://web.archive.org/web/20211127121316if_/https://typora.io/linux/typora_${PV}_amd64.deb"
12 #TODO : update license
13 S="${WORKDIR}/usr"
14 LICENSE="typora"
15 SLOT="0"
16 KEYWORDS="-* ~amd64"
18 RESTRICT="mirror"
20 RDEPEND="x11-libs/libXScrnSaver"
22 QA_PREBUILT="*"
24 src_prepare() {
25 rm -rf share/lintian || die
26 sed -i '/Change Log/d' share/applications/typora.desktop || die
27 default
30 src_install() {
31 local dir="/opt/${PN}"
33 insinto "${dir}"
34 doins -r bin share
36 fperms 0755 "${dir}/bin/typora"
37 fperms 4755 "${dir}/share/typora/chrome-sandbox"
38 dosym -r /opt/typora/bin/typora /usr/bin/typora
40 domenu share/applications/typora.desktop