dev-python/conda-libmamba-solver: bump version to 24.11.1
[gentoo-zh.git] / app-i18n / fcitx-cskk / fcitx-cskk-1.2.0.ebuild
blob93e7e1e0ea5113550f21b554d74232349b03a58c
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 MY_PN="fcitx5-cskk"
8 inherit cmake
10 DESCRIPTION="SKK input method plugin for fcitx5 that uses LibCSKK"
11 HOMEPAGE="https://github.com/fcitx/fcitx5-cskk"
12 SRC_URI="https://github.com/fcitx/fcitx5-cskk/archive/v${PV}.tar.gz -> ${P}.tar.gz"
14 LICENSE="GPL-3+"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="+qt5"
19 DEPEND="
20 app-i18n/cskk
21 >=app-i18n/fcitx-5.0.6:5
22 app-i18n/fcitx-qt[qt5?,-onlyplugin]
23 app-i18n/libskk
24 app-i18n/skk-jisyo
25 qt5? (
26 dev-qt/qtcore:5
27 dev-qt/qtgui:5
28 dev-qt/qtwidgets:5
31 RDEPEND="${DEPEND}"
32 BDEPEND="
33 kde-frameworks/extra-cmake-modules
34 virtual/pkgconfig
37 S="${WORKDIR}/${MY_PN}-${PV}"
39 src_configure() {
40 local mycmakeargs=(
41 -DENABLE_QT=$(usex qt5)
43 cmake_src_configure