1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit desktop xdg-utils
8 DESCRIPTION
="A notebook based on p2p network"
9 HOMEPAGE
="https://anytype.io"
10 SRC_URI
="https://anytype-release.fra1.cdn.digitaloceanspaces.com/Anytype-${PV}.AppImage
11 https://anytype-release.fra1.cdn.digitaloceanspaces.com/anytype_${PV}_amd64.deb"
20 RDEPEND
="sys-fs/fuse:0"
21 BDEPEND
="app-arch/dpkg"
26 cp "${DISTDIR}/Anytype-$PV.AppImage" anytype-bin || die
31 dpkg
-x "${DISTDIR}"/anytype_
${PV}_amd64.deb . || die
"dpkg icon extraction failed"
32 sed -i 's|Exec=/opt/Anytype/anytype %U|Exec=anytype-bin %U|g' usr
/share
/applications
/anytype.desktop ||
33 die
"Sed Exec command failed"
38 for size
in 16 32 64 128 256 512 1024; do
39 doicon
-s "$size" usr
/share
/icons
/hicolor
/"$size"x
"$size"/apps
/anytype.png || die
"Icon installation failed"
41 domenu usr
/share
/applications
/anytype.desktop || die
"Desktop file installation failed"
45 xdg_desktop_database_update
49 xdg_desktop_database_update