1 # Copyright 2017-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 PYTHON_COMPAT
=( python3_
{10.
.12} )
6 DISTUTILS_SINGLE_IMPL
="1"
7 DISTUTILS_USE_PEP517
=setuptools
11 DESCRIPTION
="GYP (Generate Your Projects) meta-build system"
12 HOMEPAGE
="https://gyp.gsrc.io/ https://chromium.googlesource.com/external/gyp"
14 if [[ "${PV}" == "99999999999999" ]]; then
16 EGIT_REPO_URI
="https://chromium.googlesource.com/external/gyp"
22 RDEPEND
="$(python_gen_cond_dep 'dev-python/six[${PYTHON_USEDEP}]')"
24 python_prepare_all
() {
25 distutils-r1_python_prepare_all
27 sed -e "s/' Linux %s' % ' '\.join(platform.linux_distribution())/' Linux'/" -i gyptest.py || die
28 sed -e "s/the_dict_key is 'variables'/the_dict_key == 'variables'/" -i pylib
/gyp
/input.py || die
30 -e "s/os\.environ\['PRESERVE'\] is not ''/os.environ['PRESERVE'] != ''/" \
31 -e "s/conditions is ()/conditions == ()/" \
32 -i test
/lib
/TestCmd.py || die
36 # More errors with DeprecationWarnings enabled.
37 local -x PYTHONWARNINGS
=""
39 "${PYTHON}" gyptest.py
--all --verbose