1 # Copyright 2021-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 DESCRIPTION
="A cross-platform (C99/C++11) process library"
9 HOMEPAGE
="https://github.com/DaanDeMeyer/reproc"
10 SRC_URI
="https://github.com/DaanDeMeyer/reproc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
14 KEYWORDS
="~amd64 ~arm64 ~x86"
18 multilib_src_configure
() {
20 -DCMAKE_BUILD_TYPE=Release
21 -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
22 -DCMAKE_INSTALL_LIBDIR=$
(get_libdir
)
23 -DBUILD_SHARED_LIBS=ON
25 -DREPROC_TEST=$
(usex
test)