dev-python/conda-libmamba-solver: bump version to 24.11.1
[gentoo-zh.git] / dev-cpp / tl-expected / tl-expected-1.1.0.ebuild
blobccd9da89fd3eb09de7303b99875c5b1826262f66
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake
8 SRC_URI="https://github.com/TartanLlama/expected/archive/v${PV}.tar.gz -> ${P}.tar.gz"
9 KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
10 S="${WORKDIR}/${PN##tl-}-${PV}"
12 DESCRIPTION="Guideline Support Library implementation by Microsoft"
13 HOMEPAGE="https://github.com/TartanLlama/expected"
15 LICENSE="CC0-1.0"
16 SLOT="0"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
20 # header only library
21 BDEPEND="test? ( dev-cpp/catch:1 )"
23 PATCHES=("${FILESDIR}/1.0.0-use_system_catch.patch")
25 src_configure() {
26 local mycmakeargs=(
27 -DEXPECTED_BUILD_TESTS=$(usex test)
29 use test && mycmakeargs+=( -DFORCE_SYSTEM_CATCH=ON )
30 cmake_src_configure