dev-python/conda-libmamba-solver: bump version to 24.11.1
[gentoo-zh.git] / dev-util / asdf-vm / asdf-vm-0.14.1.ebuild
blob8c5f066d07054613ae7c5d67a598fdd0bf904ff4
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit bash-completion-r1
8 DESCRIPTION="Manage all your runtime versions with one tool"
9 HOMEPAGE="https://github.com/asdf-vm/asdf"
10 SRC_URI="https://github.com/asdf-vm/asdf/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11 S="${WORKDIR}/asdf-${PV}"
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="amd64 arm64"
17 RDEPEND="
18         net-misc/curl
19         dev-vcs/git
22 DOCS=( CHANGELOG.md README.md )
24 src_install() {
25         dodoc README.md
27         insinto /opt/${PN}
28         doins -r bin
29         doins -r lib
30         doins asdf.{elv,fish,nu,ps1,sh}
31         doins defaults
32         doins help.txt
33         doins version.txt
35         fperms +x /opt/${PN}/bin/asdf
36         fperms +x /opt/${PN}/bin/private/asdf-exec
37         fperms +x /opt/${PN}/asdf.{elv,fish,nu,ps1,sh}
39         dobashcomp completions/asdf.bash
41         insinto /usr/share/zsh/site-functions
42         doins completions/_asdf
44         insinto /usr/share/fish/vendor_completions.d
45         doins completions/asdf.fish