dev-python/conda-libmamba-solver: bump version to 24.11.1
[gentoo-zh.git] / dev-util / cargo-about / cargo-about-0.6.6.ebuild
blob46ffc8c5bfb623324f3936a74eafb048d6e2d60b
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.4
6 EAPI=8
8 CRATES="
9         addr2line@0.24.2
10         adler2@2.0.0
11         aho-corasick@1.1.3
12         anstream@0.6.18
13         anstyle-parse@0.2.6
14         anstyle-query@1.1.2
15         anstyle-wincon@3.0.6
16         anstyle@1.0.10
17         anyhow@1.0.93
18         askalono@0.5.0
19         assert_cmd@2.0.16
20         assert_fs@1.1.2
21         autocfg@1.4.0
22         backtrace@0.3.74
23         base64@0.22.1
24         bitflags@2.6.0
25         block-buffer@0.10.4
26         bstr@1.11.0
27         bumpalo@3.16.0
28         byteorder@1.5.0
29         bytes@1.8.0
30         camino@1.1.9
31         cargo-platform@0.1.8
32         cargo_metadata@0.18.1
33         cc@1.2.1
34         cd@0.3.0
35         cfg-expr@0.17.1
36         cfg-if@1.0.0
37         cfg_aliases@0.2.1
38         clap@4.5.21
39         clap_builder@4.5.21
40         clap_derive@4.5.18
41         clap_lex@0.7.3
42         codespan-reporting@0.11.1
43         codespan@0.11.1
44         colorchoice@1.0.3
45         core-foundation-sys@0.8.7
46         core-foundation@0.9.4
47         cpufeatures@0.2.15
48         crc32fast@1.4.2
49         crossbeam-deque@0.8.5
50         crossbeam-epoch@0.9.18
51         crossbeam-utils@0.8.20
52         crypto-common@0.1.6
53         deranged@0.3.11
54         difflib@0.4.0
55         digest@0.10.7
56         displaydoc@0.2.5
57         doc-comment@0.3.3
58         either@1.13.0
59         equivalent@1.0.1
60         errno@0.3.9
61         fastrand@2.2.0
62         fern@0.7.0
63         fixedbitset@0.4.2
64         flate2@1.0.35
65         float-cmp@0.9.0
66         fnv@1.0.7
67         form_urlencoded@1.2.1
68         futures-channel@0.3.31
69         futures-core@0.3.31
70         futures-io@0.3.31
71         futures-sink@0.3.31
72         futures-task@0.3.31
73         futures-util@0.3.31
74         generic-array@0.14.7
75         getrandom@0.2.15
76         gimli@0.31.1
77         globset@0.4.15
78         globwalk@0.9.1
79         handlebars@6.2.0
80         hashbrown@0.15.1
81         heck@0.5.0
82         hermit-abi@0.3.9
83         home@0.5.9
84         http-body-util@0.1.2
85         http-body@1.0.1
86         http@1.1.0
87         httparse@1.9.5
88         hyper-rustls@0.27.3
89         hyper-util@0.1.10
90         hyper@1.5.0
91         icu_collections@1.5.0
92         icu_locid@1.5.0
93         icu_locid_transform@1.5.0
94         icu_locid_transform_data@1.5.0
95         icu_normalizer@1.5.0
96         icu_normalizer_data@1.5.0
97         icu_properties@1.5.1
98         icu_properties_data@1.5.0
99         icu_provider@1.5.0
100         icu_provider_macros@1.5.0
101         idna@1.0.3
102         idna_adapter@1.2.0
103         ignore@0.4.23
104         indexmap@2.6.0
105         ipnet@2.10.1
106         is_terminal_polyfill@1.70.1
107         itoa@1.0.11
108         jobserver@0.1.32
109         js-sys@0.3.72
110         krates@0.17.5
111         lazy_static@1.5.0
112         libc@0.2.162
113         libmimalloc-sys@0.1.39
114         linux-raw-sys@0.4.14
115         litemap@0.7.3
116         lock_api@0.4.12
117         log@0.4.22
118         memchr@2.7.4
119         mimalloc@0.1.43
120         mime@0.3.17
121         miniz_oxide@0.8.0
122         mio@1.0.2
123         normalize-line-endings@0.3.0
124         nu-ansi-term@0.50.1
125         num-conv@0.1.0
126         num-modular@0.6.1
127         num-order@1.2.0
128         num-traits@0.2.19
129         object@0.36.5
130         once_cell@1.20.2
131         openssl-probe@0.1.5
132         parking_lot@0.12.3
133         parking_lot_core@0.9.10
134         paste@1.0.15
135         percent-encoding@2.3.1
136         pest@2.7.14
137         pest_derive@2.7.14
138         pest_generator@2.7.14
139         pest_meta@2.7.14
140         petgraph@0.6.5
141         pin-project-lite@0.2.15
142         pin-utils@0.1.0
143         pkg-config@0.3.31
144         powerfmt@0.2.0
145         ppv-lite86@0.2.20
146         predicates-core@1.0.8
147         predicates-tree@1.0.11
148         predicates@3.1.2
149         proc-macro2@1.0.89
150         quinn-proto@0.11.9
151         quinn-udp@0.5.7
152         quinn@0.11.6
153         quote@1.0.37
154         rand@0.8.5
155         rand_chacha@0.3.1
156         rand_core@0.6.4
157         rayon-core@1.12.1
158         rayon@1.10.0
159         redox_syscall@0.5.7
160         regex-automata@0.4.9
161         regex-syntax@0.8.5
162         regex@1.11.1
163         reqwest@0.12.9
164         ring@0.17.8
165         rmp-serde@1.3.0
166         rmp@0.8.14
167         rustc-demangle@0.1.24
168         rustc-hash@2.0.0
169         rustix@0.38.40
170         rustls-native-certs@0.8.0
171         rustls-pemfile@2.2.0
172         rustls-pki-types@1.10.0
173         rustls-webpki@0.102.8
174         rustls@0.23.16
175         ryu@1.0.18
176         same-file@1.0.6
177         schannel@0.1.26
178         scopeguard@1.2.0
179         security-framework-sys@2.12.1
180         security-framework@2.11.1
181         semver@1.0.23
182         serde@1.0.215
183         serde_derive@1.0.215
184         serde_json@1.0.132
185         serde_spanned@0.6.8
186         serde_urlencoded@0.7.1
187         sha2@0.10.8
188         shlex@1.3.0
189         slab@0.4.9
190         smallvec@1.13.2
191         socket2@0.5.7
192         spdx@0.10.7
193         spin@0.9.8
194         stable_deref_trait@1.2.0
195         strsim@0.11.1
196         subtle@2.6.1
197         syn@2.0.87
198         sync_wrapper@1.0.1
199         synstructure@0.13.1
200         tempfile@3.14.0
201         termcolor@1.4.1
202         termtree@0.4.1
203         thiserror-impl@1.0.69
204         thiserror-impl@2.0.3
205         thiserror@1.0.69
206         thiserror@2.0.3
207         time-core@0.1.2
208         time@0.3.36
209         tinystr@0.7.6
210         tinyvec@1.8.0
211         tinyvec_macros@0.1.1
212         tokio-rustls@0.26.0
213         tokio@1.41.1
214         toml@0.8.19
215         toml_datetime@0.6.8
216         toml_edit@0.22.22
217         tower-service@0.3.3
218         tracing-core@0.1.32
219         tracing@0.1.40
220         try-lock@0.2.5
221         twox-hash@2.0.1
222         typenum@1.17.0
223         ucd-trie@0.1.7
224         unicode-ident@1.0.13
225         unicode-normalization@0.1.24
226         unicode-width@0.1.14
227         untrusted@0.9.0
228         url@2.5.3
229         utf16_iter@1.0.5
230         utf8_iter@1.0.4
231         utf8parse@0.2.2
232         version_check@0.9.5
233         wait-timeout@0.2.0
234         walkdir@2.5.0
235         want@0.3.1
236         wasi@0.11.0+wasi-snapshot-preview1
237         wasm-bindgen-backend@0.2.95
238         wasm-bindgen-futures@0.4.45
239         wasm-bindgen-macro-support@0.2.95
240         wasm-bindgen-macro@0.2.95
241         wasm-bindgen-shared@0.2.95
242         wasm-bindgen@0.2.95
243         web-sys@0.3.72
244         web-time@1.1.0
245         webpki-roots@0.26.6
246         winapi-util@0.1.9
247         windows-registry@0.2.0
248         windows-result@0.2.0
249         windows-strings@0.1.0
250         windows-sys@0.52.0
251         windows-sys@0.59.0
252         windows-targets@0.52.6
253         windows_aarch64_gnullvm@0.52.6
254         windows_aarch64_msvc@0.52.6
255         windows_i686_gnu@0.52.6
256         windows_i686_gnullvm@0.52.6
257         windows_i686_msvc@0.52.6
258         windows_x86_64_gnu@0.52.6
259         windows_x86_64_gnullvm@0.52.6
260         windows_x86_64_msvc@0.52.6
261         winnow@0.6.20
262         write16@1.0.0
263         writeable@0.5.5
264         yoke-derive@0.7.4
265         yoke@0.7.4
266         zerocopy-derive@0.7.35
267         zerocopy@0.7.35
268         zerofrom-derive@0.1.4
269         zerofrom@0.1.4
270         zeroize@1.8.1
271         zerovec-derive@0.10.3
272         zerovec@0.10.4
273         zstd-safe@7.2.1
274         zstd-sys@2.0.13+zstd.1.5.6
275         zstd@0.13.2
276         ${PN}@${PV}
279 inherit cargo
281 DESCRIPTION="Cargo plugin to generate list of all licenses for a crate"
282 HOMEPAGE="https://github.com/EmbarkStudios/cargo-about"
283 SRC_URI="
284         ${CARGO_CRATE_URIS}
287 LICENSE="|| ( Apache-2.0 MIT )"
288 # Dependent crate licenses
289 LICENSE+=" Apache-2.0 BSD ISC MIT MPL-2.0 Unicode-3.0 Unicode-DFS-2016"
290 SLOT="0"
291 KEYWORDS="~amd64"