dev-python/conda-libmamba-solver: bump version to 24.11.1
[gentoo-zh.git] / games-fps / source-engine / source-engine-9999.ebuild
blob488a59a7de3b2f3f9d60fcb720557f565df4adf8
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 PYTHON_COMPAT=( python3_11 python3_12 )
7 PYTHON_REQ_USE='threads(+)'
9 inherit waf-utils git-r3 python-any-r1
11 DESCRIPTION="A 3D game engine developed by Valve"
12 HOMEPAGE="https://github.com/nillerusr/source-engine"
13 EGIT_REPO_URI="https://github.com/nillerusr/source-engine.git"
15 LICENSE="Source-SDK"
16 SLOT="0"
17 IUSE="debug"
18 BDEPEND="${PYTHON_DEPS}
19 media-libs/libsdl2
20 media-libs/freetype
21 media-libs/fontconfig
22 sys-libs/zlib
23 media-libs/libjpeg-turbo
24 media-libs/libpng
25 net-misc/curl
26 media-libs/openal"
28 src_configure() {
29 local conf=(
30 '-8'
31 $(usex debug '-T debug' '-T release')
33 waf-utils_src_configure "${conf[@]}"
36 src_install() {
37 waf-utils_src_install --destdir="${ED}/opt/source-engine"
40 pkg_postinst() {
41 einfo "To play Half-Life 2,"
42 einfo "you must legally own a Half-Life 2 copy,"
43 einfo "then copy the 'hl2' folder into"
44 einfo "/opt/source-engine/usr"