1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 PYTHON_COMPAT
=( python3_11 python3_12
)
7 PYTHON_REQ_USE
='threads(+)'
9 inherit waf-utils git-r3 python-any-r1
11 DESCRIPTION
="A 3D game engine developed by Valve"
12 HOMEPAGE
="https://github.com/nillerusr/source-engine"
13 EGIT_REPO_URI
="https://github.com/nillerusr/source-engine.git"
18 BDEPEND
="${PYTHON_DEPS}
23 media-libs/libjpeg-turbo
31 $
(usex debug
'-T debug' '-T release')
33 waf-utils_src_configure
"${conf[@]}"
37 waf-utils_src_install
--destdir="${ED}/opt/source-engine"
41 einfo
"To play Half-Life 2,"
42 einfo
"you must legally own a Half-Life 2 copy,"
43 einfo
"then copy the 'hl2' folder into"
44 einfo
"/opt/source-engine/usr"