dev-python/conda-libmamba-solver: bump version to 24.11.1
[gentoo-zh.git] / media-sound / barva / barva-9999.ebuild
blob2b4726ef31cd4636d29d7d63ffd060b386d0cc27
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit git-r3 toolchain-funcs
8 DESCRIPTION="a modular audio visualizer"
9 HOMEPAGE="https://github.com/Kharacternyk/barva"
10 EGIT_REPO_URI="https://github.com/Kharacternyk/barva.git"
11 EGIT_BRANCH="legacy"
13 LICENSE="GPL-3"
14 SLOT="0"
15 DEPEND="media-libs/libpulse"
16 src_compile() {
17 emake CC="$(tc-getCC)" -C src
20 src_install() {
21 dobin "${S}/src/${PN}"
22 dodoc "${S}/README.rst"
24 into /usr/share/${PN}
25 dobin "${S}/scripts/pa-get-default-monitor.sh"
26 dobin "${S}/scripts/bspwm-borders.sh"
27 dobin "${S}/scripts/to-all-ttys.sh"
30 pkg_postinst() {
31 elog "The usage documentation should be installed in /usr/share/doc/barva-9999"
32 elog "scripts are stored in /usr/share/barva"
34 ewarn "Please note that, the bundled script pa-get-default-monitor.sh,"
35 ewarn "is currently broken."
36 ewarn "please manually specify BARVA_SOURCE instead."