1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 VERIFY_SIG_OPENPGP_KEY_PATH
=${BROOT}/usr
/share
/openpgp-keys
/libidn.asc
7 inherit elisp-common libtool multilib-minimal verify-sig
11 DESCRIPTION
="Internationalized Domain Names (IDN) implementation"
12 HOMEPAGE
="https://www.gnu.org/software/libidn/"
13 SRC_URI
="mirror://gnu/libidn/${MY_P}.tar.gz
14 verify-sig? ( mirror://gnu/libidn/${MY_P}.tar.gz.sig )"
16 LICENSE
="GPL-2 GPL-3 LGPL-3"
23 S
="${WORKDIR}/libidn-1.33"
25 DOCS
=( AUTHORS ChangeLog FAQ NEWS README THANKS
)
28 nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
37 nls? ( >=sys-devel/gettext-0.17 )
38 verify-sig? ( app-crypt/openpgp-keys-libidn )
44 # For Solaris shared objects
48 multilib_src_configure
() {
54 --disable-valgrind-tests
55 --with-lispdir="${EPREFIX}${SITELISP}/${PN}"
56 --with-packager-bug-reports="https://bugs.gentoo.org"
57 --with-packager-version="r${PR}"
58 --with-packager="Gentoo"
61 ECONF_SOURCE
="${S}" econf
"${args[@]}"
65 # Only run libidn specific tests and not gnulib tests (bug #539356)
69 multilib_src_install
() {
70 emake DESTDIR
="${D}" install
73 multilib_src_install_all
() {
74 find "${ED}" -name '*.la' -delete || die
75 find "${ED}" -name 'libidn.so' -delete || die
76 rm -rf ${ED}/usr
/include
77 rm -rf ${ED}/usr
/*/pkgconfig
78 rm -rf ${ED}/usr
/share