1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 MY_PV
="$(ver_cut 1-3)T$(ver_cut 4-7)Z"
11 COMMIT_ID
=1681e4497c09d7438a34e846f76dbde972ab7daf
13 DESCRIPTION
="Minio client provides alternatives for ls, cat on cloud storage and filesystems"
14 HOMEPAGE
="https://github.com/minio/mc"
16 https://github.com/minio/mc/archive/RELEASE.${MY_PV}.tar.gz -> ${P}.tar.gz
17 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-vendor.tar.xz
20 S
="${WORKDIR}/${PN}-RELEASE.${MY_PV}"
21 LICENSE
="Apache-2.0 BSD MIT MPL-2.0"
25 RDEPEND
="!!app-misc/mc"
28 # go run buildscripts/gen-ldflags.go
29 local ldflags
="-s -w \
30 -X github.com/minio/mc/cmd.Version=${MY_PV} \
31 -X github.com/minio/mc/cmd.CopyrightYear=${YEAR} \
32 -X github.com/minio/mc/cmd.ReleaseTag=RELEASE.${MY_PV} \
33 -X github.com/minio/mc/cmd.CommitID=${COMMIT_ID}"
34 ego build
-trimpath --ldflags "${ldflags}"
39 dodoc README.md CONTRIBUTING.md