dev-python/conda-libmamba-solver: bump version to 24.11.1
[gentoo-zh.git] / net-fs / mc / mc-2024.11.21.17.21.54.ebuild
blob821e9547515a973f94d163188490a93c2d257dd1
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit go-module
8 MY_PV="$(ver_cut 1-3)T$(ver_cut 4-7)Z"
9 MY_PV=${MY_PV//./-}
10 YEAR="$(ver_cut 1)"
11 COMMIT_ID=1681e4497c09d7438a34e846f76dbde972ab7daf
13 DESCRIPTION="Minio client provides alternatives for ls, cat on cloud storage and filesystems"
14 HOMEPAGE="https://github.com/minio/mc"
15 SRC_URI="
16 https://github.com/minio/mc/archive/RELEASE.${MY_PV}.tar.gz -> ${P}.tar.gz
17 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-vendor.tar.xz
20 S="${WORKDIR}/${PN}-RELEASE.${MY_PV}"
21 LICENSE="Apache-2.0 BSD MIT MPL-2.0"
22 SLOT="0"
23 KEYWORDS="~amd64"
25 RDEPEND="!!app-misc/mc"
27 src_compile() {
28 # go run buildscripts/gen-ldflags.go
29 local ldflags="-s -w \
30 -X github.com/minio/mc/cmd.Version=${MY_PV} \
31 -X github.com/minio/mc/cmd.CopyrightYear=${YEAR} \
32 -X github.com/minio/mc/cmd.ReleaseTag=RELEASE.${MY_PV} \
33 -X github.com/minio/mc/cmd.CommitID=${COMMIT_ID}"
34 ego build -trimpath --ldflags "${ldflags}"
37 src_install() {
38 dobin mc
39 dodoc README.md CONTRIBUTING.md