dev-python/conda-libmamba-solver: bump version to 24.11.1
[gentoo-zh.git] / net-libs / jzmq / jzmq-9999.ebuild
blob03cfc88831f51a0fc92f6a0d566590291b85694c
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit git-r3 autotools
7 DESCRIPTION="jzmq"
8 HOMEPAGE="http://www.zeromq.org/bindings:java"
10 if [[ ${PV} == "9999" ]] ; then
11 EGIT_REPO_URI="https://github.com/zeromq/jzmq.git"
12 vcs=git-r3
15 LICENSE="LGPL-3"
16 SLOT="0"
18 DEPEND="net-libs/zeromq
19 >=virtual/jre-1.7:*"
20 RDEPEND="${DEPEND}"
22 S="${WORKDIR}/${P}/${PN}-jni"
24 src_prepare() {
25 default
26 eautoreconf
29 src_configure() {
30 PATH=/etc/java-config-2/current-system-vm/bin:$PATH
31 PKG_CONFIG=/usr/lib64/pkgconfig/
32 eautomake
33 econf
36 src_install() {
37 emake DESTDIR="${D}" install || die "emake install failed"
38 dodoc README ChangeLog || die "dodoc failed"