1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Auto-Generated by cargo-ebuild 0.5.4
32 brotli-decompressor@2.3.2
47 checked_int_cast@1.0.0
53 cocoa-foundation@0.1.0
65 core-foundation-sys@0.8.3
67 core-graphics-types@0.1.1
70 crossbeam-channel@0.5.5
73 crossbeam-utils@0.8.10
77 cssparser-macros@0.6.0
109 foreign-types-shared@0.1.1
110 form_urlencoded@1.1.0
113 futures-channel@0.3.21
115 futures-executor@0.3.21
124 gdk-pixbuf-sys@0.15.10
166 indicatif@0.17.0-rc.11
173 javascriptcore-rs@0.16.0
174 javascriptcore-rs-sys@0.4.0
186 linked-hash-map@0.5.6
191 mac-notification-sys@0.5.5
209 new_debug_unreachable@1.0.4
220 num_enum_derive@0.5.7
224 objc-foundation@0.1.1
240 parking_lot_core@0.9.3
244 percent-encoding@2.2.0
255 pin-project-lite@0.2.9
265 precomputed-hash@0.1.1
266 proc-macro-crate@1.1.3
267 proc-macro-error@1.0.4
268 proc-macro-error-attr@1.0.4
269 proc-macro-hack@0.5.19
283 raw-window-handle@0.5.0
289 regex-automata@0.1.10
293 reqwest-middleware@0.1.6
295 reqwest_cookie_store@0.2.0
311 scoped_threadpool@0.1.9
314 security-framework@2.6.1
315 security-framework-sys@2.6.1
326 serde_urlencoded@0.7.1
328 serde_with_macros@1.5.2
330 serialize-to-javascript@0.1.1
331 serialize-to-javascript-impl@0.1.1
338 signal-hook-registry@1.4.0
347 stable_deref_trait@1.2.0
352 stdweb-internal-macros@0.2.9
353 stdweb-internal-runtime@0.1.5
355 string_cache_codegen@0.5.2
366 task-local-extensions@0.1.1
372 tauri-runtime-wry@0.12.0
381 thiserror-impl@1.0.31
388 time-macros-impl@0.1.2
393 tokio-native-tls@0.3.0
399 tracing-appender@0.2.2
400 tracing-attributes@0.1.22
403 tracing-subscriber@0.3.14
412 unicode-normalization@0.1.21
413 unicode-segmentation@1.10.0
423 version-compare@0.0.11
424 version-compare@0.1.0
428 wasi@0.9.0+wasi-snapshot-preview1
429 wasi@0.11.0+wasi-snapshot-preview1
431 wasm-bindgen-backend@0.2.81
432 wasm-bindgen-futures@0.4.31
433 wasm-bindgen-macro@0.2.81
434 wasm-bindgen-macro-support@0.2.81
435 wasm-bindgen-shared@0.2.81
438 webkit2gtk-sys@0.18.0
442 webview2-com-macros@0.6.0
443 webview2-com-sys@0.19.0
446 winapi-i686-pc-windows-gnu@0.4.0
448 winapi-x86_64-pc-windows-gnu@0.4.0
453 windows-bindgen@0.39.0
454 windows-implement@0.39.0
455 windows-metadata@0.39.0
457 windows-tokens@0.39.0
458 windows_aarch64_msvc@0.32.0
459 windows_aarch64_msvc@0.36.1
460 windows_aarch64_msvc@0.37.0
461 windows_aarch64_msvc@0.39.0
462 windows_i686_gnu@0.24.0
463 windows_i686_gnu@0.32.0
464 windows_i686_gnu@0.36.1
465 windows_i686_gnu@0.37.0
466 windows_i686_gnu@0.39.0
467 windows_i686_msvc@0.24.0
468 windows_i686_msvc@0.32.0
469 windows_i686_msvc@0.36.1
470 windows_i686_msvc@0.37.0
471 windows_i686_msvc@0.39.0
472 windows_x86_64_gnu@0.24.0
473 windows_x86_64_gnu@0.32.0
474 windows_x86_64_gnu@0.36.1
475 windows_x86_64_gnu@0.37.0
476 windows_x86_64_gnu@0.39.0
477 windows_x86_64_msvc@0.24.0
478 windows_x86_64_msvc@0.32.0
479 windows_x86_64_msvc@0.36.1
480 windows_x86_64_msvc@0.37.0
481 windows_x86_64_msvc@0.39.0
484 winrt-notification@0.5.1
495 inherit desktop cargo xdg
497 MY_P
="${PN}-app-v${PV}"
499 DESCRIPTION
="A Tool for Upload video to bilibili"
500 # Double check the homepage as the cargo_metadata crate
501 # does not provide this value so instead repository is used
502 # tauri package need node_modules, see https://github.com/123485k/gentoo-tauri-node-dep
503 HOMEPAGE
="https://github.com/ForgQi/biliup-app"
505 https://github.com/ForgQi/${PN}/archive/refs/tags/app-v${PV}.tar.gz -> ${P}.tar.gz
506 https://github.com/123485k/gentoo-tauri-node-dep/releases/download/${P}/${P}-node_modules.tar.xz
508 S
="${WORKDIR}/${MY_P}"
509 # License set may be more restrictive as OR is not respected
510 # use cargo-license for a more accurate license picture
511 LICENSE
="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD Boost-1.0 CC0-1.0 ISC MIT MIT-0 MPL-2.0 Unicode-DFS-2016 Unlicense ZLIB"
513 KEYWORDS
="~amd64 ~arm64"
516 net-libs/webkit-gtk:4
522 !net-misc/biliup-app-bin
525 # rust does not use *FLAGS from make.conf, silence portage warning
526 # update with proper path to binaries this crate installs, omit leading /
527 QA_FLAGS_IGNORED
="usr/bin/${PN}"
531 ln -sf "${WORKDIR}/node_modules" "${S}/" || die
536 # use tauri build and run ps -ef | grep cargo | head to get features
544 cd "${WORKDIR}/${MY_P}"/src-tauri || die
549 cd "${WORKDIR}/${MY_P}"/src-tauri || die
550 MY_CARGO_BUILD_DIR
=$
(cargo_target_dir
)
551 newbin
"${MY_CARGO_BUILD_DIR}"/app
"${PN}"
552 newicon
-s 256 "${S}/src-tauri/icons/128x128@2x.png" "${PN}.png"
553 newicon
-s 128 "${S}/src-tauri/icons/128x128.png" "${PN}.png"
554 newicon
-s 32 "${S}/src-tauri/icons/32x32.png" "${PN}.png"
555 domenu
"${FILESDIR}/${PN}.desktop"