dev-python/conda-libmamba-solver: bump version to 24.11.1
[gentoo-zh.git] / net-misc / bruno-bin / bruno-bin-1.35.0.ebuild
blob04250387531ade81a903e75368562555c1a08ef0
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit unpacker desktop xdg
8 DESCRIPTION="Opensource IDE For Exploring and Testing Api's"
9 HOMEPAGE="https://www.usebruno.com/"
10 SRC_URI="https://github.com/usebruno/bruno/releases/download/v${PV}/bruno_${PV}_amd64_linux.deb"
12 S="${WORKDIR}"
13 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64"
18 RDEPEND="net-libs/webkit-gtk:4"
20 RESTRICT="strip"
22 src_install() {
23 insinto /opt/Bruno
24 doins -r "${S}"/opt/Bruno/.
25 fperms +x /opt/Bruno/bruno
26 fperms +x /opt/Bruno/chrome-sandbox
27 fperms +x /opt/Bruno/chrome_crashpad_handler
29 domenu "${S}"/usr/share/applications/bruno.desktop
31 for size in 16 24 32 48 64 128 256 512 1024; do
32 doicon -s ${size} "${S}"/usr/share/icons/hicolor/${size}x${size}/apps/bruno.png
33 done