1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit unpacker desktop xdg
8 DESCRIPTION
="Opensource IDE For Exploring and Testing Api's"
9 HOMEPAGE
="https://www.usebruno.com/"
10 SRC_URI
="https://github.com/usebruno/bruno/releases/download/v${PV}/bruno_${PV}_amd64_linux.deb"
18 RDEPEND
="net-libs/webkit-gtk:4"
24 doins
-r "${S}"/opt
/Bruno
/.
25 fperms
+x
/opt
/Bruno
/bruno
26 fperms
+x
/opt
/Bruno
/chrome-sandbox
27 fperms
+x
/opt
/Bruno
/chrome_crashpad_handler
29 domenu
"${S}"/usr
/share
/applications
/bruno.desktop
31 for size
in 16 24 32 48 64 128 256 512 1024; do
32 doicon
-s ${size} "${S}"/usr/share/icons/hicolor/${size}x${size}/apps
/bruno.png