1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit autotools flag-o-matic
8 DESCRIPTION
="PCMan is a gtk+ based free BBS client"
9 HOMEPAGE
="https://github.com/pcman-bbs/pcmanx"
10 SRC_URI
="https://github.com/pcman-bbs/pcmanx/releases/download/${PV}/${P}.tar.xz"
15 IUSE
="+libnotify +proxy iplookup +wget"
18 libnotify? ( x11-libs/libnotify )
25 wget? ( net-misc/wget )
34 DOCS
=( TODO README NEWS ChangeLog AUTHORS
)
39 # this flag crashes CTermData::memset16()
40 filter-flags
-ftree-vectorize
45 econf $
(use_enable proxy
) \
46 $
(use_enable libnotify
) \
48 $
(use_enable iplookup
)