dev-python/conda-libmamba-solver: bump version to 24.11.1
[gentoo-zh.git] / net-misc / pcmanx-gtk2 / pcmanx-gtk2-1.3.ebuild
blob4dfafd681e253e2041b6f98c4f51a5d88120268a
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit autotools flag-o-matic
8 DESCRIPTION="PCMan is a gtk+ based free BBS client"
9 HOMEPAGE="https://github.com/pcman-bbs/pcmanx"
10 SRC_URI="https://github.com/pcman-bbs/pcmanx/releases/download/${PV}/${P}.tar.xz"
12 KEYWORDS="~amd64"
13 SLOT="0"
14 LICENSE="GPL-2"
15 IUSE="+libnotify +proxy iplookup +wget"
17 COMMON_DEPEND="
18 libnotify? ( x11-libs/libnotify )
19 x11-libs/libXft
20 >=x11-libs/gtk+-2.4:2
23 RDEPEND="
24 ${COMMON_DEPEND}
25 wget? ( net-misc/wget )
28 DEPEND="
29 ${COMMON_DEPEND}
30 dev-util/intltool
31 sys-devel/gettext
34 DOCS=( TODO README NEWS ChangeLog AUTHORS )
36 src_prepare() {
37 eautoreconf
39 # this flag crashes CTermData::memset16()
40 filter-flags -ftree-vectorize
41 eapply_user
44 src_configure() {
45 econf $(use_enable proxy) \
46 $(use_enable libnotify) \
47 $(use_enable wget)\
48 $(use_enable iplookup)