dev-python/conda-libmamba-solver: add 24.9.0, drop 24.1.0-r1
[gentoo-zh.git] / gui-libs / libdecor / libdecor-0.1.1.ebuild
blob7a320ed51601481335efb1f2da22b9720e1958ae
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit meson
8 DESCRIPTION="A client-side decorations library for Wayland clients"
9 HOMEPAGE="https://gitlab.freedesktop.org/libdecor/libdecor"
10 SRC_URI="https://gitlab.freedesktop.org/libdecor/libdecor/-/archive/${PV}/${P}.tar.bz2"
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~amd64"
15 IUSE="+dbus examples"
17 DEPEND="
18         >=dev-libs/wayland-1.18
19         >=dev-libs/wayland-protocols-1.15
20         x11-libs/pango
21         dbus? ( sys-apps/dbus )
22         examples? (
23                 virtual/opengl
24                 media-libs/mesa[egl(+)]
25                 x11-libs/libxkbcommon
26         )
28 RDEPEND="${DEPEND}"
30 src_configure() {
31         local emesonargs=(
32                 # Avoid auto-magic, built-in feature of meson
33                 -Dauto_features=disabled
35                 $(meson_feature dbus)
36                 $(meson_use examples demo)
37                 -Dinstall_demo=true
38         )
40         meson_src_configure