dev-python/conda-libmamba-solver: add 24.9.0, drop 24.1.0-r1
[gentoo-zh.git] / net-misc / baidupcs-go / baidupcs-go-3.9.5.ebuild
blob198622fbfee8d2de195f27dba2e375551c4439fa
1 # Copyright 2020-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 MY_PN="BaiduPCS-Go"
8 inherit go-module
10 if [[ ${PV} == *9999 ]]; then
11         inherit git-r3
12         EGIT_REPO_URI="https://github.com/qjfoidnh/${MY_PN}.git"
13         src_unpack() {
14                 git-r3_src_unpack
15         }
16 else
17         SRC_URI="https://github.com/qjfoidnh/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
18                 https://github.com/liangyongxiang/gentoo-go-deps/releases/download/${P}/${P}-deps.tar.xz"
19         KEYWORDS="~amd64 ~x86"
20         S="${WORKDIR}/${MY_PN}-${PV}"
23 DESCRIPTION="The terminal utility for Baidu Network Disk (Golang Version)."
24 HOMEPAGE="https://github.com/qjfoidnh/BaiduPCS-Go"
26 LICENSE="Apache-2.0"
27 SLOT="0"
29 src_compile()
31         ego build -o bin/${PN} -trimpath
34 src_install() {
35         dobin bin/${PN}