dev-db/mongodb: fix mask format
[gentoo-zh.git] / dev-libs / libthai / libthai-0.1.28.ebuild
blob2d6dcffdd5b951dcb597c939b619b6cf43ce284c
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit autotools
8 DESCRIPTION="A a set of Thai language support routines"
9 HOMEPAGE="https://github.com/tlwg/libthai"
11 if [[ ${PV} == "9999" ]] ; then
12 inherit git-r3
13 EGIT_REPO_URI="https://github.com/tlwg/${PN}.git"
14 else
15 SRC_URI="https://github.com/tlwg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
16 KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
19 LICENSE="LGPL-2.1"
20 SLOT="0"
22 RDEPEND="dev-libs/libdatrie"
23 DEPEND="${RDEPEND}"
24 BDEPEND="dev-vcs/git"
26 PATCHES=(
27 "${FILESDIR}/${P}-fix-duplicate-dir.patch" #fix autoconf-2.7
30 src_prepare() {
31 default
32 # Fixed version if in non git project
33 echo ${PV} > VERSION
34 # From upstreams autogen.sh, to make it utilize the autotools eclass
35 # Here translate the autogen.sh, equivalent to the following code
36 # > sh autogen.sh
38 _elibtoolize --force
39 eaclocal
40 eautomake --add-missing
41 # Not allow git-version-gen does refresh
42 eautoconf