dev-db/mongodb: fix mask format
[gentoo-zh.git] / dev-python / conda / conda-4.12.0.ebuild
blob829ca2e626b2928a3c3d632743bee81d8a8865e5
1 # Copyright 2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 PYTHON_COMPAT=( python3_9 )
7 inherit distutils-r1
9 DESCRIPTION="OS-agnostic, system-level binary package manager and ecosystem"
10 HOMEPAGE="https://conda.io/"
11 SRC_URI="https://github.com/conda/conda/archive/${PV}.tar.gz -> ${P}.tar.gz"
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="amd64 ~x86"
17 DEPEND="dev-vcs/git
18 dev-python/pyopenssl[${PYTHON_USEDEP}]
19 dev-python/requests[${PYTHON_USEDEP}]
20 dev-python/ruamel-yaml[${PYTHON_USEDEP}]
21 dev-python/conda-package-handling[${PYTHON_USEDEP}]
22 dev-python/pycosat[${PYTHON_USEDEP}]"
23 RDEPEND="${DEPEND}"
24 BDEPEND=""
26 IUSE="+user"
28 distutils_enable_tests pytest
30 python_prepare_all() {
31 echo ${PV} > conda/.version || die
32 distutils-r1_python_prepare_all
35 python_install() {
36 distutils-r1_python_install
37 rm "${ED}/usr/bin/conda" || die
38 cp "${S}/conda/shell/bin/conda" "${ED}/usr/bin/conda" || die
39 # no need for Python Byte compiling and multi python slot, please do not use python_doscript
40 # this ebuild just use one stable python target
43 python_install_all() {
44 if use user ; then
45 insinto /etc/conda
46 doins "${FILESDIR}/condarc"
50 pkg_postinst() {
51 elog "Initialize conda for shell interaction, "
52 elog "run 'conda init shells' "
53 elog "Currently compatible shells are {bash, fish, powershell, tcsh, xonsh, zsh}"
54 elog "base environment is managed by portage, do not use conda in base env!"