sys-kernel/xanmod-{kernel, sources}: bump to 6.11.9
[gentoo-zh.git] / games-misc / oh-my-git-bin / oh-my-git-bin-0.6.5.ebuild
blobfcf51f3120d40bff8a968d65e2dbad731668db5d
1 # Copyright 2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 MY_PN=${PN/-bin}
7 MY_PATH=/opt/${MY_PN}
9 DESCRIPTION="An interactive Git learning game!"
10 HOMEPAGE="https://ohmygit.org/
11 https://github.com/git-learning-game/oh-my-git"
12 PKG_URI="https://blinry.itch.io/oh-my-git"
13 SRC_URI="${MY_PN}-linux.zip"
15 LICENSE="BlueOak-1.0.0"
16 SLOT="0"
17 KEYWORDS="~amd64"
18 RESTRICT="fetch"
20 DEPEND="
21 media-libs/alsa-lib
22 media-libs/libglvnd
23 media-libs/libpulse
24 x11-libs/libX11
25 x11-libs/libXcursor
26 x11-libs/libXi
27 x11-libs/libXinerama
28 x11-libs/libXrandr
29 x11-libs/libXrender
31 RDEPEND="${DEPEND}"
32 BDEPEND="app-arch/unzip"
34 S="${WORKDIR}"
36 pkg_nofetch() {
37 elog "Please download ${A} from"
38 elog "${PKG_URI}"
39 elog "and place it in your DISTDIR directory."
42 src_install() {
43 insinto ${MY_PATH}
44 doins ${MY_PN}
45 doins ${MY_PN}.pck
46 dosym ../..${MY_PATH}/${MY_PN} /usr/bin/${MY_PN}
47 fperms +x ${MY_PATH}/${MY_PN}