net-p2p/qbittorrent-enhanced: fix variable location and bump to 4.6.7.10
[gentoo-zh.git] / media-plugins / waylyrics / waylyrics-0.3.13.ebuild
blob467f3e8db8fad10a0cbe187efd1914b997bff499
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.2
6 EAPI=8
8 CRATES="
9         addr2line@0.22.0
10         adler@1.0.2
11         aes@0.8.4
12         ahash@0.7.8
13         ahash@0.8.11
14         aho-corasick@1.1.3
15         ansi_term@0.12.1
16         anyhow@1.0.86
17         arrayvec@0.7.4
18         ashpd@0.8.1
19         assert_float_eq@1.1.3
20         async-broadcast@0.7.1
21         async-channel@2.3.1
22         async-executor@1.12.0
23         async-fs@2.1.2
24         async-io@2.3.3
25         async-lock@3.4.0
26         async-net@2.0.0
27         async-process@2.2.3
28         async-recursion@1.1.1
29         async-signal@0.2.8
30         async-task@4.7.1
31         async-trait@0.1.80
32         atk-sys@0.18.0
33         atk@0.18.0
34         atomic-waker@1.1.2
35         atty@0.2.14
36         autocfg@1.3.0
37         backtrace@0.3.73
38         base64@0.22.1
39         base64ct@1.6.0
40         bitflags@1.3.2
41         bitflags@2.6.0
42         bitvec@1.0.1
43         block-buffer@0.10.4
44         block-padding@0.3.3
45         block@0.1.6
46         blocking@1.6.1
47         borsh-derive@1.5.1
48         borsh@1.5.1
49         bumpalo@3.16.0
50         bytecheck@0.6.12
51         bytecheck_derive@0.6.12
52         byteorder@1.5.0
53         bytes@1.6.0
54         cairo-rs@0.18.5
55         cairo-rs@0.19.4
56         cairo-sys-rs@0.18.2
57         cairo-sys-rs@0.19.2
58         cbc@0.1.2
59         cc@1.0.101
60         cfg-expr@0.15.8
61         cfg-if@1.0.0
62         cfg_aliases@0.1.1
63         cfg_aliases@0.2.1
64         cipher@0.4.4
65         clap@2.34.0
66         cocoa-foundation@0.1.2
67         cocoa@0.25.0
68         concurrent-queue@2.5.0
69         const-oid@0.9.6
70         cookie@0.18.1
71         cookie_store@0.21.0
72         core-foundation-sys@0.8.6
73         core-foundation@0.9.4
74         core-graphics-types@0.1.3
75         core-graphics@0.23.2
76         cpufeatures@0.2.12
77         crc32fast@1.4.2
78         crossbeam-channel@0.5.13
79         crossbeam-utils@0.8.20
80         crypto-common@0.1.6
81         darling@0.14.4
82         darling_core@0.14.4
83         darling_macro@0.14.4
84         dbus-codegen@0.9.1
85         dbus-tree@0.9.2
86         dbus@0.9.7
87         der@0.7.9
88         deranged@0.3.11
89         derive_is_enum_variant@0.1.1
90         digest@0.10.7
91         directories@5.0.1
92         dirs-sys@0.4.1
93         dirs@5.0.1
94         dispatch@0.2.0
95         documented-derive@0.5.0
96         documented@0.5.0
97         dpi@0.1.1
98         ecb@0.1.2
99         embed-resource@2.4.2
100         encoding_rs@0.8.34
101         endi@1.1.0
102         enum-kinds@0.5.1
103         enumflags2@0.7.10
104         enumflags2_derive@0.7.10
105         equivalent@1.0.1
106         errno@0.3.9
107         event-listener-strategy@0.5.2
108         event-listener@5.3.1
109         fastrand@2.1.0
110         fdeflate@0.3.4
111         field-offset@0.3.6
112         flate2@1.0.30
113         fnv@1.0.7
114         foreign-types-macros@0.2.3
115         foreign-types-shared@0.1.1
116         foreign-types-shared@0.3.1
117         foreign-types@0.3.2
118         foreign-types@0.5.0
119         form_urlencoded@1.2.1
120         from_variants@1.0.2
121         from_variants_impl@1.0.2
122         funty@2.0.0
123         futures-channel@0.3.30
124         futures-core@0.3.30
125         futures-executor@0.3.30
126         futures-io@0.3.30
127         futures-lite@2.3.0
128         futures-macro@0.3.30
129         futures-sink@0.3.30
130         futures-task@0.3.30
131         futures-util@0.3.30
132         gdk-pixbuf-sys@0.18.0
133         gdk-pixbuf-sys@0.19.8
134         gdk-pixbuf@0.18.5
135         gdk-pixbuf@0.19.8
136         gdk-sys@0.18.0
137         gdk4-sys@0.8.2
138         gdk4-win32-sys@0.8.2
139         gdk4-win32@0.8.2
140         gdk4@0.8.2
141         gdk@0.18.0
142         generic-array@0.14.7
143         getrandom@0.2.15
144         gettext-rs@0.7.0
145         gettext-sys@0.21.3
146         gimli@0.29.0
147         gio-sys@0.18.1
148         gio-sys@0.19.8
149         gio@0.18.4
150         gio@0.19.8
151         glib-macros@0.18.5
152         glib-macros@0.19.9
153         glib-sys@0.18.1
154         glib-sys@0.19.8
155         glib@0.18.5
156         glib@0.19.9
157         gobject-sys@0.18.0
158         gobject-sys@0.19.8
159         graphene-rs@0.19.8
160         graphene-sys@0.19.8
161         gsk4-sys@0.8.2
162         gsk4@0.8.2
163         gtk-sys@0.18.0
164         gtk3-macros@0.18.0
165         gtk4-macros@0.8.2
166         gtk4-sys@0.8.2
167         gtk4@0.8.2
168         gtk@0.18.1
169         h2@0.4.5
170         hashbrown@0.12.3
171         hashbrown@0.14.5
172         heck@0.3.3
173         heck@0.4.1
174         heck@0.5.0
175         hermit-abi@0.1.19
176         hermit-abi@0.3.9
177         hermit-abi@0.4.0
178         hex@0.4.3
179         http-body-util@0.1.2
180         http-body@1.0.0
181         http@1.1.0
182         httparse@1.9.4
183         hyper-rustls@0.27.2
184         hyper-tls@0.6.0
185         hyper-util@0.1.5
186         hyper@1.3.1
187         ident_case@1.0.1
188         idna@0.3.0
189         idna@0.5.0
190         indexmap@2.2.6
191         inout@0.1.3
192         ipnet@2.9.0
193         itoa@1.0.11
194         js-sys@0.3.69
195         keyboard-types@0.7.0
196         ksni@0.2.2
197         lazy_static@1.5.0
198         libappindicator-sys@0.9.0
199         libappindicator@0.9.0
200         libc@0.2.155
201         libdbus-sys@0.2.5
202         libloading@0.7.4
203         libm@0.2.8
204         libmimalloc-sys@0.1.39
205         libredox@0.1.3
206         libxdo-sys@0.11.0
207         libxdo@0.6.0
208         linux-raw-sys@0.4.14
209         locale_config@0.3.0
210         lock_api@0.4.12
211         log@0.4.21
212         lrc-nom@0.3.0
213         malloc_buf@0.0.6
214         matchers@0.1.0
215         md5@0.7.0
216         memchr@2.7.4
217         memoffset@0.9.1
218         mimalloc@0.1.43
219         mime@0.3.17
220         minimal-lexical@0.2.1
221         miniz_oxide@0.7.4
222         mio@0.8.11
223         mpris@2.0.1
224         muda@0.13.5
225         native-tls@0.2.12
226         ncmapi2@0.1.13
227         nix@0.28.0
228         nom@7.1.3
229         nu-ansi-term@0.46.0
230         num-bigint-dig@0.8.4
231         num-conv@0.1.0
232         num-integer@0.1.46
233         num-iter@0.1.45
234         num-traits@0.2.19
235         num_cpus@1.16.0
236         objc-foundation@0.1.1
237         objc@0.2.7
238         objc_id@0.1.1
239         object@0.36.0
240         once_cell@1.19.0
241         opencc-rust@1.1.18
242         openssl-macros@0.1.1
243         openssl-probe@0.1.5
244         openssl-sys@0.9.102
245         openssl@0.10.64
246         optfield@0.3.0
247         option-ext@0.2.0
248         ordered-stream@0.2.0
249         overload@0.1.1
250         pango-sys@0.18.0
251         pango-sys@0.19.8
252         pango@0.18.3
253         pango@0.19.8
254         parking@2.2.0
255         parking_lot@0.12.3
256         parking_lot_core@0.9.10
257         pem-rfc7468@0.7.0
258         percent-encoding@2.3.1
259         phf@0.11.2
260         phf_generator@0.11.2
261         phf_macros@0.11.2
262         phf_shared@0.11.2
263         pin-project-internal@1.1.5
264         pin-project-lite@0.2.14
265         pin-project@1.1.5
266         pin-utils@0.1.0
267         piper@0.2.3
268         pkcs1@0.7.5
269         pkcs8@0.10.2
270         pkg-config@0.3.30
271         png@0.17.13
272         polling@3.7.2
273         pollster@0.3.0
274         powerfmt@0.2.0
275         ppv-lite86@0.2.17
276         proc-macro-crate@1.3.1
277         proc-macro-crate@2.0.0
278         proc-macro-crate@3.1.0
279         proc-macro-error-attr@1.0.4
280         proc-macro-error@1.0.4
281         proc-macro2@1.0.86
282         psl-types@2.0.11
283         ptr_meta@0.1.4
284         ptr_meta_derive@0.1.4
285         publicsuffix@2.2.3
286         qqmusic-rs@0.1.0
287         quote@0.3.15
288         quote@1.0.36
289         radium@0.7.0
290         rand@0.8.5
291         rand_chacha@0.3.1
292         rand_core@0.6.4
293         raw-window-handle@0.6.2
294         redox_syscall@0.5.2
295         redox_users@0.4.5
296         regex-automata@0.1.10
297         regex-automata@0.4.7
298         regex-syntax@0.6.29
299         regex-syntax@0.8.4
300         regex@1.10.5
301         rend@0.4.2
302         reqwest@0.12.5
303         rfd@0.14.1
304         ring@0.17.8
305         rkyv@0.7.44
306         rkyv_derive@0.7.44
307         rsa@0.9.6
308         rust_decimal@1.35.0
309         rust_decimal_macros@1.34.2
310         rustc-demangle@0.1.24
311         rustc_version@0.4.0
312         rustix@0.38.34
313         rustls-pemfile@2.1.2
314         rustls-pki-types@1.7.0
315         rustls-webpki@0.102.4
316         rustls@0.23.10
317         rustversion@1.0.17
318         ryu@1.0.18
319         schannel@0.1.23
320         scopeguard@1.2.0
321         seahash@4.1.0
322         security-framework-sys@2.11.0
323         security-framework@2.11.0
324         semver@1.0.23
325         serde@1.0.203
326         serde_derive@1.0.203
327         serde_json@1.0.118
328         serde_repr@0.1.19
329         serde_spanned@0.6.6
330         serde_urlencoded@0.7.1
331         sha1@0.10.6
332         sharded-slab@0.1.7
333         signal-hook-registry@1.4.2
334         signature@2.2.0
335         simd-adler32@0.3.7
336         simdutf8@0.1.4
337         siphasher@0.3.11
338         slab@0.4.9
339         smallvec@1.13.2
340         socket2@0.5.7
341         sorensen@0.2.0
342         spin@0.9.8
343         spki@0.7.3
344         static_assertions@1.1.0
345         strsim@0.10.0
346         strsim@0.8.0
347         strum@0.26.3
348         strum_macros@0.26.4
349         subtle@2.6.1
350         syn@0.11.11
351         syn@1.0.109
352         syn@2.0.68
353         syn_derive@0.1.8
354         sync_wrapper@1.0.1
355         synom@0.11.3
356         sys-locale@0.3.1
357         system-configuration-sys@0.5.0
358         system-configuration@0.5.1
359         system-deps@6.2.2
360         tap@1.0.1
361         target-lexicon@0.12.14
362         temp-dir@0.1.13
363         tempfile@3.10.1
364         textwrap@0.11.0
365         thiserror-impl@1.0.61
366         thiserror@1.0.61
367         thread_local@1.1.8
368         time-core@0.1.2
369         time-macros@0.2.18
370         time@0.3.36
371         tinyvec@1.6.1
372         tinyvec_macros@0.1.1
373         tokio-macros@2.3.0
374         tokio-native-tls@0.3.1
375         tokio-rustls@0.26.0
376         tokio-util@0.7.11
377         tokio@1.38.0
378         toml@0.8.14
379         toml_datetime@0.6.6
380         toml_edit@0.19.15
381         toml_edit@0.20.7
382         toml_edit@0.21.1
383         toml_edit@0.22.14
384         tower-layer@0.3.2
385         tower-service@0.3.2
386         tower@0.4.13
387         tracing-attributes@0.1.27
388         tracing-core@0.1.32
389         tracing-journald@0.3.0
390         tracing-log@0.2.0
391         tracing-subscriber@0.3.18
392         tracing@0.1.40
393         tray-icon@0.14.3
394         try-lock@0.2.5
395         typenum@1.17.0
396         uds_windows@1.1.0
397         unicode-bidi@0.3.15
398         unicode-ident@1.0.12
399         unicode-normalization@0.1.23
400         unicode-segmentation@1.11.0
401         unicode-width@0.1.13
402         unicode-xid@0.0.4
403         untrusted@0.9.0
404         url@2.5.2
405         urlencoding@2.1.3
406         uuid@1.9.1
407         valuable@0.1.0
408         vcpkg@0.2.15
409         vec_map@0.8.2
410         version-compare@0.2.0
411         version_check@0.9.4
412         vswhom-sys@0.1.2
413         vswhom@0.1.0
414         want@0.3.1
415         wasi@0.11.0+wasi-snapshot-preview1
416         wasm-bindgen-backend@0.2.92
417         wasm-bindgen-futures@0.4.42
418         wasm-bindgen-macro-support@0.2.92
419         wasm-bindgen-macro@0.2.92
420         wasm-bindgen-shared@0.2.92
421         wasm-bindgen@0.2.92
422         web-sys@0.3.69
423         winapi-i686-pc-windows-gnu@0.4.0
424         winapi-x86_64-pc-windows-gnu@0.4.0
425         winapi@0.3.9
426         windows-core@0.57.0
427         windows-implement@0.57.0
428         windows-interface@0.57.0
429         windows-result@0.1.2
430         windows-sys@0.48.0
431         windows-sys@0.52.0
432         windows-targets@0.48.5
433         windows-targets@0.52.5
434         windows@0.57.0
435         windows_aarch64_gnullvm@0.48.5
436         windows_aarch64_gnullvm@0.52.5
437         windows_aarch64_msvc@0.48.5
438         windows_aarch64_msvc@0.52.5
439         windows_exe_info@0.4.2
440         windows_i686_gnu@0.48.5
441         windows_i686_gnu@0.52.5
442         windows_i686_gnullvm@0.52.5
443         windows_i686_msvc@0.48.5
444         windows_i686_msvc@0.52.5
445         windows_x86_64_gnu@0.48.5
446         windows_x86_64_gnu@0.52.5
447         windows_x86_64_gnullvm@0.48.5
448         windows_x86_64_gnullvm@0.52.5
449         windows_x86_64_msvc@0.48.5
450         windows_x86_64_msvc@0.52.5
451         winnow@0.5.40
452         winnow@0.6.13
453         winreg@0.52.0
454         wyz@0.5.1
455         x11@2.21.0
456         xdg-home@1.2.0
457         xml-rs@0.8.20
458         zbus@4.3.0
459         zbus_macros@4.3.0
460         zbus_names@3.0.0
461         zerocopy-derive@0.7.34
462         zerocopy@0.7.34
463         zeroize@1.8.1
464         zvariant@4.1.1
465         zvariant_derive@4.1.1
466         zvariant_utils@2.0.0
469 PLOCALES="en_US zh_CN"
470 inherit cargo desktop gnome2-utils plocale xdg
472 DESCRIPTION="Simple On Screen lyrics Display for linux/unix"
473 HOMEPAGE="
474         https://waylyrics.github.io/waylyrics/waylyrics
475         https://github.com/waylyrics/waylyrics
478 if [[ "${PV}" == *9999* ]]; then
479         inherit git-r3
480         EGIT_REPO_URI="https://github.com/waylyrics/waylyrics.git"
481 else
482         SRC_URI="
483                 https://github.com/waylyrics/waylyrics/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
484                 ${CARGO_CRATE_URIS}
485         "
486         KEYWORDS="~amd64 ~loong"
489 LICENSE="MIT CC-BY-4.0"
490 # Dependent crate licenses
491 LICENSE+="
492         Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD GPL-3+ ISC MIT
493         MPL-2.0 Unicode-DFS-2016 Unlicense
495 SLOT="0"
497 DEPEND="
498         dev-libs/glib:2
499         app-i18n/opencc
500         dev-libs/openssl:=
501         gnome-base/dconf
502         gui-libs/gtk:4
503         sys-apps/dbus
504         sys-devel/gettext
505         x11-libs/cairo
507 RDEPEND="
508         ${DEPEND}
509         sys-apps/xdg-desktop-portal
511 BDEPEND="
512         >=virtual/rust-1.73:*
515 src_compile() {
516         export WAYLYRICS_THEME_PRESETS_DIR="/usr/share/${PN}/themes"
517         cargo_src_compile --all-targets --all-features
520 src_install() {
521         cargo_src_install
523         doicon -s scalable "${S}/res/icons/hicolor/scalable/apps/io.github.waylyrics.Waylyrics.svg"
524         domenu "${S}/metainfo/io.github.waylyrics.Waylyrics.desktop"
526         insinto "/usr/share/glib-2.0/schemas"
527         doins "${S}/metainfo/io.github.waylyrics.Waylyrics.gschema.xml"
529         insinto "/usr/share/metainfo"
530         doins "${S}/metainfo/io.github.waylyrics.Waylyrics.metainfo.xml"
532         insinto "/usr/share/${PN}"
533         doins -r themes
535         cd "${S}/locales" || die
536         install_locale() {
537                 if [[ -f ${1}/LC_MESSAGES/waylyrics.po ]]; then
538                         local file=${1}/LC_MESSAGES/waylyrics.po
539                         msgfmt "${file}" -o "${file%.po}.mo" || die
540                         insinto /usr/share/locale/${1}/LC_MESSAGES
541                         doins "${file%.po}.mo"
542                 fi
543         }
544         plocale_for_each_locale install_locale
547 pkg_postinst() {
548         gnome2_schemas_update
549         xdg_pkg_postinst
552 pkg_postrm() {
553         gnome2_schemas_update
554         xdg_pkg_postrm