1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 MY_PGK_NAME
="com.alibabainc.dingtalk"
7 inherit desktop unpacker xdg
9 DESCRIPTION
="Communication platform that supports video and audio conferencing"
10 HOMEPAGE
="https://gov.dingtalk.com"
11 SRC_URI
="https://dtapp-pub.dingtalk.com/dingtalk-desktop/xc_dingtalk_update/linux_deb/Release/com.alibabainc.${PN}_${PV}_amd64.deb"
13 LICENSE
="all-rights-reserved"
17 RESTRICT
="strip mirror bindist"
23 media-libs/tiff-compat:4
33 x11-libs/libXScrnSaver
39 BDEPEND
="dev-util/patchelf"
46 # Install scalable icon
47 doicon
-s scalable
"${FILESDIR}"/dingtalk.svg
48 # Remove the libraries that break compatibility in modern systems
49 # Dingtalk will use the system libs instead
50 MY_VERSION
=$
(cat "${S}"/opt
/apps
/"${MY_PGK_NAME}"/files
/version
)
52 rm -f "${S}"/opt/apps/"${MY_PGK_NAME}"/files/"${MY_VERSION}"/libstdc
++* || die
54 rm -f "${S}"/opt/apps/"${MY_PGK_NAME}"/files/"${MY_VERSION}"/libm.so
* || die
56 rm -f "${S}"/opt/apps/"${MY_PGK_NAME}"/files/"${MY_VERSION}"/libz
* || die
57 # Use system libcurl, fix preserved depend problem
58 rm -f "${S}"/opt/apps/"${MY_PGK_NAME}"/files/"${MY_VERSION}"/libcurl.so
* || die
59 # use system freetype, fix undefined symbol: FT_Get_Color_Glyph_Layer
60 rm -rf "${S}"/opt/apps/"${MY_PGK_NAME}"/files/"${MY_VERSION}"/libfreetype.so
* || die
62 # Set RPATH for preserve-libs handling
63 pushd "${S}"/opt/apps/"${MY_PGK_NAME}"/files/"${MY_VERSION}" || die
66 # Use \x7fELF header to separate ELF executables and libraries
67 [[ -f ${x} && $
(od -t x1
-N 4 "${x}") == *"7f 45 4c 46"* ]] ||
continue
68 local RPATH_ROOT
="/opt/apps/${MY_PGK_NAME}/files/${MY_VERSION}"
69 patchelf
--set-rpath "${RPATH_ROOT}/:${RPATH_ROOT}/swiftshader/:${RPATH_ROOT}/platforminputcontexts/:${RPATH_ROOT}/imageformats/" "${x}" || \
70 die
"patchelf failed on ${x}"
73 # fix ldd pattern error
74 sed -i 's/libc_version=.*/libc_version=`ldd --version | grep ldd | rev | cut -d" " -f1 | rev`/g' "${S}"/opt
/apps
/"${MY_PGK_NAME}"/files
/Elevator.sh || die
76 sed -i "s/export XMODIFIERS/#export XMODIFIERS/g" "${S}"/opt
/apps
/"${MY_PGK_NAME}"/files
/Elevator.sh || die
77 sed -i "s/export QT_IM_MODULE/#export QT_IM_MODULE/g" "${S}"/opt
/apps
/"${MY_PGK_NAME}"/files
/Elevator.sh || die
79 cat >> "${S}"/opt
/apps
/"${MY_PGK_NAME}"/files
/Elevator.sh.
head <<- EOF || die
81 if [ -z "\${QT_IM_MODULE}" ]
83 if [ -n "\$(pidof fcitx5)" ]
85 export XMODIFIERS="@im=fcitx"
86 export QT_IM_MODULE=fcitx
87 elif [ -n "\$(pidof ibus-daemon)" ]
89 export XMODIFIERS="@im=ibus"
90 export QT_IM_MODULE=ibus
91 elif [ -n "\$(pidof fcitx)" ]
93 export XMODIFIERS="@im=fcitx"
94 export QT_IM_MODULE=fcitx
99 cat "${S}"/opt/apps/"${MY_PGK_NAME}"/files/Elevator.sh.head "${S}"/opt/apps/"${MY_PGK_NAME}"/files/Elevator.sh > "${S}"/opt/apps/"${MY_PGK_NAME}"/files
/Elevator.sh.new || die
100 cat "${S}"/opt/apps/"${MY_PGK_NAME}"/files/Elevator.sh.new > "${S}"/opt/apps/"${MY_PGK_NAME}"/files
/Elevator.sh || die
101 rm "${S}"/opt/apps/"${MY_PGK_NAME}"/files/Elevator.sh.head "${S}"/opt/apps/"${MY_PGK_NAME}"/files
/Elevator.sh.new || die
103 # Add dingtalk command
104 mkdir
-p "${S}"/usr
/bin
/ || die
105 ln -s /opt
/apps
/"${MY_PGK_NAME}"/files
/Elevator.sh
"${S}"/usr
/bin
/dingtalk || die
107 # Fix file path and desktop files
108 sed -E -i 's/^Icon=.*$/Icon=dingtalk/g' "${S}"/opt
/apps
/"${MY_PGK_NAME}"/entries
/applications
/*.desktop || die
110 mkdir
-p usr
/share
/applications || die
111 mv "${S}"/opt/apps/"${MY_PGK_NAME}"/entries/applications/"${MY_PGK_NAME}".desktop usr
/share
/applications
/ || die
113 # Install package and fix permissions
115 doins
-r opt
/apps
/${MY_PGK_NAME}
120 for x
in $
(find "opt/apps/${MY_PGK_NAME}") ; do
121 # Fix shell script permissions
122 [[ "${x: -3}" == ".sh" ]] && fperms
0755 "/${x}"
123 # Use \x7fELF header to separate ELF executables and libraries
124 [[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] && fperms 0755 "/${x}"