media-sound/netease-cloud-music-gtk: add 2.4.1, drop 2.4.0
[gentoo-zh.git] / sci-libs / libtifiles2 / libtifiles2-9999.ebuild
blobd1186635439c235a61b4a81914e00ffeebdcb4ce
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit autotools git-r3
8 DESCRIPTION="Library for TI calculator files"
9 HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
11 EGIT_REPO_URI="https://github.com/debrouxl/tilibs.git"
13 MY_PN="libtifiles"
15 LICENSE="GPL-2"
16 SLOT="0"
17 IUSE="doc nls static-libs"
19 RDEPEND="
20         app-arch/libarchive
21         dev-libs/glib:2
22         >=sci-libs/libticables2-1.3.3
23         >=sci-libs/libticonv-1.1.3
24         nls? ( virtual/libintl )"
26 DEPEND="${RDEPEND}
27         virtual/pkgconfig
28         nls? ( sys-devel/gettext )"
30 DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
32 src_prepare() {
33         S="${S}/${MY_PN}/trunk/"
34         cd "${S}"
36         eautoreconf
39 src_configure() {
40         econf \
41                 --disable-rpath \
42                 $(use_enable nls) \
43                 $(use_enable static-libs static)
46 src_install() {
47         default
48         use doc && dohtml docs/html/*