gui-apps/crystal-dock: new package, add 2.7
[gentoo-zh.git] / app-arch / zchunk / zchunk-1.5.1.ebuild
blobf6721f055810ad130251a3abba507b225cdad7a2
1 # Copyright 2017-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit meson
7 if [[ ${PV} == 9999* ]] ; then
8         inherit git-r3
9         EGIT_REPO_URI="https://github.com/zchunk/zchunk.git"
10         EGIT_CHECKOUT_DIR=${PN}-${PV}
11 else
12         SRC_URI="https://github.com/zchunk/zchunk/archive/refs/tags/${PV}.tar.gz -> ${PN}-${PV}.tar.gz"
13         KEYWORDS="~amd64 ~riscv"
14         S="${WORKDIR}/${PN}-${PV}"
17 DESCRIPTION="A format designed for highly efficient deltas while maintaining good compression"
18 HOMEPAGE="https://github.com/zchunk/zchunk"
19 LICENSE="BSD-2"
20 SLOT="0"
21 IUSE="doc +curl +openssl test +zstd"
22 RESTRICT="!test? ( test )"
24 DEPEND="
25         curl? ( net-misc/curl )
26         openssl? ( dev-libs/openssl:0/3 )
27         zstd? ( app-arch/zstd )
29 RDEPEND="${DEPEND}"
31 src_configure() {
32         local emesonargs=(
33                 -Dcoverity=false
34                 $(meson_feature curl with-curl)
35                 $(meson_use doc docs)
36                 $(meson_feature openssl with-openssl)
37                 $(meson_feature zstd with-zstd)
38                 $(meson_use test tests)
39         )
40         meson_src_configure