gui-apps/crystal-dock: new package, add 2.7
[gentoo-zh.git] / app-backup / btrfs-assistant / btrfs-assistant-9999.ebuild
blob756a4bf0349e7fc8d7824025c844d5e1bd9f5268
1 #Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit xdg cmake git-r3 optfeature
7 EGIT_REPO_URI="${HOMEPAGE}"
9 DESCRIPTION="A GUI management tool to make managing a Btrfs filesystem easier."
10 HOMEPAGE="https://gitlab.com/btrfs-assistant/btrfs-assistant"
12 LICENSE="GPL-3"
13 SLOT="0"
15 DEPEND="
16         dev-qt/qtbase:6
17         dev-qt/qtsvg:6
19 BDEPEND="${DEPEND}"
20 RDEPEND="
21         media-fonts/noto
22         sys-auth/polkit
23         sys-fs/btrfs-progs
24         ${DEPEND}
27 pkg_postinst() {
28         xdg_pkg_postinst
29         optfeature "auto snapshot" app-backup/snapper
30         optfeature "auto balance and defrag" sys-fs/btrfsmaintenance