1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit unpacker desktop xdg
8 DESCRIPTION="one for all free music in China"
9 HOMEPAGE="http://listen1.github.io/listen1
10 https://github.com/listen1/listen1_desktop
13 SRC_URI="https://github.com/listen1/listen1_desktop/releases/download/v${PV}/listen1_${PV}_linux_amd64.deb -> ${P}.deb"
20 app-accessibility/at-spi2-core:2
32 x11-libs/libXcomposite
45 opt/Listen1/chrome-sandbox
47 opt/Listen1/libffmpeg.so
48 opt/Listen1/libGLESv2.so
49 opt/Listen1/libvk_swiftshader.so
50 opt/Listen1/libvulkan.so.1
52 opt/Listen1/swiftshader/libEGL.so
53 opt/Listen1/swiftshader/libGLESv2.so
58 unpack usr/share/doc/listen1/changelog.gz
59 sed -i 's/Audio/AudioVideo/' usr/share/applications/listen1.desktop || die
60 rm opt/Listen1/{LICENSE.electron.txt,LICENSES.chromium.html} || die
68 doins -r usr/share/icons
71 domenu usr/share/applications/listen1.desktop
74 for f in ${QA_PREBUILT}; do
77 fperms u+s /opt/Listen1/chrome-sandbox
79 dosym ../../opt/Listen1/listen1 /usr/bin/listen1