games-action/vintagestory: add 1.20.0, drop 1.20.0_rc8
[gentoo-zh.git] / net-misc / biliup-app / biliup-app-0.4.1-r4.ebuild
blob219a6b2c6338042a770a5dc1edfe81ff7f22c26b
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Auto-Generated by cargo-ebuild 0.5.4
6 EAPI=8
8 CRATES="
9         adler@1.0.2
10         adler32@1.2.0
11         aho-corasick@0.7.18
12         alloc-no-stdlib@2.0.3
13         alloc-stdlib@0.2.1
14         ansi_term@0.12.1
15         anyhow@1.0.58
16         async-trait@0.1.56
17         atk@0.15.1
18         atk-sys@0.15.1
19         attohttpc@0.22.0
20         atty@0.2.14
21         autocfg@0.1.8
22         autocfg@1.1.0
23         base-x@0.2.11
24         base64@0.13.0
25         base64ct@1.1.1
26         biliup@0.1.11
27         bitflags@1.3.2
28         block@0.1.6
29         block-buffer@0.9.0
30         block-buffer@0.10.2
31         brotli@3.3.4
32         brotli-decompressor@2.3.2
33         bstr@0.2.17
34         bumpalo@3.10.0
35         bytemuck@1.10.0
36         byteorder@1.4.3
37         bytes@1.1.0
38         cairo-rs@0.15.12
39         cairo-sys-rs@0.15.1
40         cargo_toml@0.13.0
41         cc@1.0.73
42         cesu8@1.1.0
43         cfb@0.6.1
44         cfg-expr@0.9.1
45         cfg-expr@0.10.3
46         cfg-if@1.0.0
47         checked_int_cast@1.0.0
48         chrono@0.4.19
49         clap@3.2.12
50         clap_derive@3.2.7
51         clap_lex@0.2.4
52         cocoa@0.24.0
53         cocoa-foundation@0.1.0
54         color_quant@1.1.0
55         combine@4.6.4
56         console@0.15.0
57         const-oid@0.6.2
58         const_fn@0.4.9
59         convert_case@0.4.0
60         cookie@0.15.1
61         cookie@0.16.0
62         cookie_store@0.15.1
63         cookie_store@0.16.1
64         core-foundation@0.9.3
65         core-foundation-sys@0.8.3
66         core-graphics@0.22.3
67         core-graphics-types@0.1.1
68         cpufeatures@0.2.2
69         crc32fast@1.3.2
70         crossbeam-channel@0.5.5
71         crossbeam-deque@0.8.1
72         crossbeam-epoch@0.9.9
73         crossbeam-utils@0.8.10
74         crypto-bigint@0.2.11
75         crypto-common@0.1.6
76         cssparser@0.27.2
77         cssparser-macros@0.6.0
78         ctor@0.1.22
79         cty@0.2.2
80         darling@0.13.4
81         darling_core@0.13.4
82         darling_macro@0.13.4
83         dbus@0.9.6
84         deflate@0.7.20
85         deflate@0.8.6
86         deflate@1.0.0
87         der@0.4.5
88         derive_more@0.99.17
89         dialoguer@0.9.0
90         digest@0.9.0
91         digest@0.10.3
92         dirs-next@2.0.0
93         dirs-sys-next@0.1.2
94         discard@1.0.4
95         dispatch@0.2.0
96         dtoa@0.4.8
97         dtoa-short@0.3.3
98         dunce@1.0.3
99         either@1.7.0
100         embed_plist@1.2.2
101         encode_unicode@0.3.6
102         encoding_rs@0.8.31
103         fastrand@1.7.0
104         field-offset@0.3.4
105         filetime@0.2.17
106         flate2@1.0.24
107         fnv@1.0.7
108         foreign-types@0.3.2
109         foreign-types-shared@0.1.1
110         form_urlencoded@1.1.0
111         futf@0.1.5
112         futures@0.3.21
113         futures-channel@0.3.21
114         futures-core@0.3.21
115         futures-executor@0.3.21
116         futures-io@0.3.21
117         futures-macro@0.3.21
118         futures-sink@0.3.21
119         futures-task@0.3.21
120         futures-util@0.3.21
121         fxhash@0.2.1
122         gdk@0.15.4
123         gdk-pixbuf@0.15.11
124         gdk-pixbuf-sys@0.15.10
125         gdk-sys@0.15.1
126         gdkx11-sys@0.15.1
127         generator@0.7.1
128         generic-array@0.14.5
129         getrandom@0.1.16
130         getrandom@0.2.7
131         gif@0.11.4
132         gio@0.15.12
133         gio-sys@0.15.10
134         glib@0.15.12
135         glib-macros@0.15.11
136         glib-sys@0.15.10
137         glob@0.3.0
138         globset@0.4.9
139         gobject-sys@0.15.10
140         gtk@0.15.5
141         gtk-sys@0.15.3
142         gtk3-macros@0.15.4
143         h2@0.3.13
144         hashbrown@0.11.2
145         hashbrown@0.12.3
146         heck@0.3.3
147         heck@0.4.0
148         hermit-abi@0.1.19
149         html5ever@0.25.2
150         http@0.2.8
151         http-body@0.4.5
152         http-range@0.1.5
153         httparse@1.7.1
154         httpdate@1.0.2
155         hyper@0.14.20
156         hyper-rustls@0.23.0
157         hyper-tls@0.5.0
158         ico@0.1.0
159         ident_case@1.0.1
160         idna@0.2.3
161         idna@0.3.0
162         ignore@0.4.18
163         image@0.23.14
164         image@0.24.2
165         indexmap@1.9.1
166         indicatif@0.17.0-rc.11
167         infer@0.7.0
168         inflate@0.3.4
169         instant@0.1.12
170         ipnet@2.5.0
171         itoa@0.4.8
172         itoa@1.0.2
173         javascriptcore-rs@0.16.0
174         javascriptcore-rs-sys@0.4.0
175         jni@0.20.0
176         jni-sys@0.3.0
177         jpeg-decoder@0.1.22
178         js-sys@0.3.58
179         json-patch@0.2.6
180         kuchiki@0.8.1
181         lazy_static@1.4.0
182         libc@0.2.126
183         libdbus-sys@0.2.2
184         libm@0.2.2
185         line-wrap@0.1.1
186         linked-hash-map@0.5.6
187         lock_api@0.4.7
188         log@0.4.17
189         loom@0.5.6
190         mac@0.1.1
191         mac-notification-sys@0.5.5
192         malloc_buf@0.0.6
193         markup5ever@0.10.1
194         matchers@0.1.0
195         matches@0.1.9
196         md-5@0.9.1
197         memchr@2.5.0
198         memoffset@0.6.5
199         mime@0.3.16
200         mime_guess@2.0.4
201         miniz_oxide@0.3.7
202         miniz_oxide@0.4.4
203         miniz_oxide@0.5.3
204         mio@0.8.4
205         native-tls@0.2.10
206         ndk@0.6.0
207         ndk-context@0.1.1
208         ndk-sys@0.3.0
209         new_debug_unreachable@1.0.4
210         nodrop@0.1.14
211         notify-rust@4.5.8
212         num-bigint-dig@0.7.0
213         num-integer@0.1.45
214         num-iter@0.1.43
215         num-rational@0.3.2
216         num-rational@0.4.1
217         num-traits@0.2.15
218         num_cpus@1.13.1
219         num_enum@0.5.7
220         num_enum_derive@0.5.7
221         num_threads@0.1.6
222         number_prefix@0.4.0
223         objc@0.2.7
224         objc-foundation@0.1.1
225         objc_exception@0.1.2
226         objc_id@0.1.1
227         once_cell@1.16.0
228         opaque-debug@0.3.0
229         open@3.0.1
230         openssl@0.10.41
231         openssl-macros@0.1.0
232         openssl-probe@0.1.5
233         openssl-sys@0.9.75
234         os_info@3.5.1
235         os_pipe@1.0.1
236         os_str_bytes@6.2.0
237         pango@0.15.10
238         pango-sys@0.15.10
239         parking_lot@0.12.1
240         parking_lot_core@0.9.3
241         paste@1.0.7
242         pathdiff@0.2.1
243         pem-rfc7468@0.2.4
244         percent-encoding@2.2.0
245         pest@2.1.3
246         phf@0.8.0
247         phf@0.10.1
248         phf_codegen@0.8.0
249         phf_generator@0.8.0
250         phf_generator@0.10.0
251         phf_macros@0.8.0
252         phf_macros@0.10.0
253         phf_shared@0.8.0
254         phf_shared@0.10.0
255         pin-project-lite@0.2.9
256         pin-utils@0.1.0
257         pkcs1@0.2.4
258         pkcs8@0.7.6
259         pkg-config@0.3.25
260         plist@1.3.1
261         png@0.11.0
262         png@0.16.8
263         png@0.17.5
264         ppv-lite86@0.2.16
265         precomputed-hash@0.1.1
266         proc-macro-crate@1.1.3
267         proc-macro-error@1.0.4
268         proc-macro-error-attr@1.0.4
269         proc-macro-hack@0.5.19
270         proc-macro2@1.0.40
271         psl-types@2.0.10
272         publicsuffix@2.1.1
273         qrcode@0.12.0
274         quote@1.0.20
275         rand@0.7.3
276         rand@0.8.5
277         rand_chacha@0.2.2
278         rand_chacha@0.3.1
279         rand_core@0.5.1
280         rand_core@0.6.3
281         rand_hc@0.2.0
282         rand_pcg@0.2.1
283         raw-window-handle@0.5.0
284         rayon@1.5.3
285         rayon-core@1.9.3
286         redox_syscall@0.2.13
287         redox_users@0.4.3
288         regex@1.6.0
289         regex-automata@0.1.10
290         regex-syntax@0.6.27
291         remove_dir_all@0.5.3
292         reqwest@0.11.11
293         reqwest-middleware@0.1.6
294         reqwest-retry@0.1.5
295         reqwest_cookie_store@0.2.0
296         retry-policies@0.1.1
297         rfd@0.10.0
298         ring@0.16.20
299         rsa@0.5.0
300         rustc_version@0.2.3
301         rustc_version@0.3.3
302         rustc_version@0.4.0
303         rustls@0.20.6
304         rustls-pemfile@1.0.0
305         rustversion@1.0.8
306         ryu@1.0.10
307         safemem@0.3.3
308         same-file@1.0.6
309         schannel@0.1.20
310         scoped-tls@1.0.0
311         scoped_threadpool@0.1.9
312         scopeguard@1.1.0
313         sct@0.7.0
314         security-framework@2.6.1
315         security-framework-sys@2.6.1
316         selectors@0.22.0
317         semver@0.9.0
318         semver@0.11.0
319         semver@1.0.12
320         semver-parser@0.7.0
321         semver-parser@0.10.2
322         serde@1.0.147
323         serde_derive@1.0.147
324         serde_json@1.0.82
325         serde_repr@0.1.8
326         serde_urlencoded@0.7.1
327         serde_with@1.14.0
328         serde_with_macros@1.5.2
329         serde_yaml@0.8.26
330         serialize-to-javascript@0.1.1
331         serialize-to-javascript-impl@0.1.1
332         servo_arc@0.1.1
333         sha1@0.6.1
334         sha1_smol@1.0.0
335         sha2@0.10.2
336         sharded-slab@0.1.4
337         shared_child@1.0.0
338         signal-hook-registry@1.4.0
339         siphasher@0.3.10
340         slab@0.4.6
341         smallvec@1.9.0
342         socket2@0.4.4
343         soup2@0.2.1
344         soup2-sys@0.2.0
345         spin@0.5.2
346         spki@0.4.1
347         stable_deref_trait@1.2.0
348         standback@0.2.17
349         state@0.5.3
350         stdweb@0.4.20
351         stdweb-derive@0.5.3
352         stdweb-internal-macros@0.2.9
353         stdweb-internal-runtime@0.1.5
354         string_cache@0.8.4
355         string_cache_codegen@0.5.2
356         strsim@0.10.0
357         strum@0.22.0
358         strum_macros@0.22.0
359         subtle@2.4.1
360         syn@1.0.98
361         synstructure@0.12.6
362         system-deps@5.0.0
363         system-deps@6.0.2
364         tao@0.15.3
365         tar@0.4.38
366         task-local-extensions@0.1.1
367         tauri@1.2.0
368         tauri-build@1.2.0
369         tauri-codegen@1.2.0
370         tauri-macros@1.2.0
371         tauri-runtime@0.12.0
372         tauri-runtime-wry@0.12.0
373         tauri-utils@1.2.0
374         tempfile@3.3.0
375         tendril@0.4.3
376         termcolor@1.1.3
377         terminal_size@0.1.17
378         textwrap@0.15.0
379         thin-slice@0.1.1
380         thiserror@1.0.31
381         thiserror-impl@1.0.31
382         thread_local@1.1.4
383         tiff@0.6.1
384         time@0.2.27
385         time@0.3.11
386         time-macros@0.1.1
387         time-macros@0.2.4
388         time-macros-impl@0.1.2
389         tinyvec@1.6.0
390         tinyvec_macros@0.1.0
391         tokio@1.20.0
392         tokio-macros@1.8.0
393         tokio-native-tls@0.3.0
394         tokio-rustls@0.23.4
395         tokio-util@0.7.3
396         toml@0.5.9
397         tower-service@0.3.2
398         tracing@0.1.35
399         tracing-appender@0.2.2
400         tracing-attributes@0.1.22
401         tracing-core@0.1.28
402         tracing-log@0.1.3
403         tracing-subscriber@0.3.14
404         treediff@3.0.2
405         try-lock@0.2.3
406         typed-builder@0.9.1
407         typenum@1.15.0
408         ucd-trie@0.1.4
409         unicase@2.6.0
410         unicode-bidi@0.3.8
411         unicode-ident@1.0.2
412         unicode-normalization@0.1.21
413         unicode-segmentation@1.10.0
414         unicode-width@0.1.9
415         unicode-xid@0.2.3
416         untrusted@0.7.1
417         url@2.3.1
418         utf-8@0.7.6
419         uuid@0.8.2
420         uuid@1.2.1
421         valuable@0.1.0
422         vcpkg@0.2.15
423         version-compare@0.0.11
424         version-compare@0.1.0
425         version_check@0.9.4
426         walkdir@2.3.2
427         want@0.3.0
428         wasi@0.9.0+wasi-snapshot-preview1
429         wasi@0.11.0+wasi-snapshot-preview1
430         wasm-bindgen@0.2.81
431         wasm-bindgen-backend@0.2.81
432         wasm-bindgen-futures@0.4.31
433         wasm-bindgen-macro@0.2.81
434         wasm-bindgen-macro-support@0.2.81
435         wasm-bindgen-shared@0.2.81
436         web-sys@0.3.58
437         webkit2gtk@0.18.2
438         webkit2gtk-sys@0.18.0
439         webpki@0.22.0
440         webpki-roots@0.22.4
441         webview2-com@0.19.1
442         webview2-com-macros@0.6.0
443         webview2-com-sys@0.19.0
444         weezl@0.1.7
445         winapi@0.3.9
446         winapi-i686-pc-windows-gnu@0.4.0
447         winapi-util@0.1.5
448         winapi-x86_64-pc-windows-gnu@0.4.0
449         windows@0.24.0
450         windows@0.32.0
451         windows@0.37.0
452         windows@0.39.0
453         windows-bindgen@0.39.0
454         windows-implement@0.39.0
455         windows-metadata@0.39.0
456         windows-sys@0.36.1
457         windows-tokens@0.39.0
458         windows_aarch64_msvc@0.32.0
459         windows_aarch64_msvc@0.36.1
460         windows_aarch64_msvc@0.37.0
461         windows_aarch64_msvc@0.39.0
462         windows_i686_gnu@0.24.0
463         windows_i686_gnu@0.32.0
464         windows_i686_gnu@0.36.1
465         windows_i686_gnu@0.37.0
466         windows_i686_gnu@0.39.0
467         windows_i686_msvc@0.24.0
468         windows_i686_msvc@0.32.0
469         windows_i686_msvc@0.36.1
470         windows_i686_msvc@0.37.0
471         windows_i686_msvc@0.39.0
472         windows_x86_64_gnu@0.24.0
473         windows_x86_64_gnu@0.32.0
474         windows_x86_64_gnu@0.36.1
475         windows_x86_64_gnu@0.37.0
476         windows_x86_64_gnu@0.39.0
477         windows_x86_64_msvc@0.24.0
478         windows_x86_64_msvc@0.32.0
479         windows_x86_64_msvc@0.36.1
480         windows_x86_64_msvc@0.37.0
481         windows_x86_64_msvc@0.39.0
482         winreg@0.10.1
483         winres@0.1.12
484         winrt-notification@0.5.1
485         wry@0.22.0
486         x11@2.19.1
487         x11-dl@2.20.0
488         xattr@0.2.3
489         xml-rs@0.8.4
490         yaml-rust@0.4.5
491         zeroize@1.4.3
492         zeroize_derive@1.3.2
495 inherit desktop cargo xdg
497 MY_P="${PN}-app-v${PV}"
499 DESCRIPTION="A Tool for Upload video to bilibili"
500 # Double check the homepage as the cargo_metadata crate
501 # does not provide this value so instead repository is used
502 # tauri package need node_modules, see https://github.com/123485k/gentoo-tauri-node-dep
503 HOMEPAGE="https://github.com/ForgQi/biliup-app"
504 SRC_URI="
505         https://github.com/ForgQi/${PN}/archive/refs/tags/app-v${PV}.tar.gz -> ${P}.tar.gz
506         https://github.com/123485k/gentoo-tauri-node-dep/releases/download/${P}/${P}-node_modules.tar.xz
507         ${CARGO_CRATE_URIS}"
508 S="${WORKDIR}/${MY_P}"
509 # License set may be more restrictive as OR is not respected
510 # use cargo-license for a more accurate license picture
511 LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD Boost-1.0 CC0-1.0 ISC MIT MIT-0 MPL-2.0 Unicode-DFS-2016 Unlicense ZLIB"
512 SLOT="0"
513 KEYWORDS="~amd64 ~arm64"
514 IUSE="debug"
515 DEPEND="
516         net-libs/webkit-gtk:4
517         x11-libs/gtk+:3
518         net-libs/nodejs[npm]
520 RDEPEND="
521         ${DEPEND}
522         !net-misc/biliup-app-bin
525 # rust does not use *FLAGS from make.conf, silence portage warning
526 # update with proper path to binaries this crate installs, omit leading /
527 QA_FLAGS_IGNORED="usr/bin/${PN}"
529 src_prepare() {
530         eapply_user
531         ln -sf "${WORKDIR}/node_modules" "${S}/" || die
534 src_configure() {
535         local myfeatures=(
536         # use tauri build and run ps -ef | grep cargo | head to get features
537                 custom-protocol
538         )
539         cargo_src_configure
542 src_compile() {
543         npm run build || die
544         cd "${WORKDIR}/${MY_P}"/src-tauri || die
545         cargo_src_compile
548 src_install() {
549         cd "${WORKDIR}/${MY_P}"/src-tauri || die
550         MY_CARGO_BUILD_DIR=$(cargo_target_dir)
551         newbin "${MY_CARGO_BUILD_DIR}"/app "${PN}"
552         newicon -s 256 "${S}/src-tauri/icons/128x128@2x.png" "${PN}.png"
553         newicon -s 128 "${S}/src-tauri/icons/128x128.png" "${PN}.png"
554         newicon -s 32 "${S}/src-tauri/icons/32x32.png" "${PN}.png"
555         domenu "${FILESDIR}/${PN}.desktop"