app-emulation/deepin-wine-helper: use python-single-r1 instead
[gentoo-zh.git] / media-plugins / osdlyrics / osdlyrics-9999.ebuild
bloba6ed6a11ff4500d13c8ef507f0a0ad3bbc683331
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
5 PYTHON_COMPAT=( python3_{8,9,10} )
7 inherit python-r1 autotools xdg
9 DESCRIPTION="Standalone lyrics fetcher/displayer (windowed and OSD mode)."
10 HOMEPAGE="https://github.com/osdlyrics/osdlyrics"
12 LICENSE="GPL-3"
13 SLOT="0"
15 if [[ "${PV}" == 9999 ]]; then
16 inherit git-r3
17 KEYWORDS=""
18 EGIT_REPO_URI="https://github.com/osdlyrics/osdlyrics.git"
19 else
20 KEYWORDS="~amd64"
21 SRC_URI="https://github.com/osdlyrics/osdlyrics/archive/${PV}.tar.gz -> ${P}.tar.gz"
24 IUSE="gnome indicator"
25 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
27 RDEPEND="
28 ${PYTHON_DEPS}
29 x11-libs/libnotify
30 dev-libs/dbus-glib
31 dev-python/chardet[${PYTHON_USEDEP}]
32 dev-python/dbus-python[${PYTHON_USEDEP}]
33 dev-python/future[${PYTHON_USEDEP}]
34 dev-python/pygobject[${PYTHON_USEDEP}]
35 dev-python/pycurl[${PYTHON_USEDEP}]
36 gnome? ( dev-libs/gobject-introspection )
37 indicator? ( dev-libs/libappindicator )
38 x11-libs/gtk+:2
41 DEPEND="
42 dev-util/intltool
43 ${RDEPEND}
46 src_prepare() {
47 default
48 eautoreconf
49 python_copy_sources
52 src_configure() {
53 configuring() {
54 local myconf=(
55 --prefix="${EPREFIX}/usr" PYTHON="${PYTHON}"
56 $(use_enable indicator appindicator)
58 econf "${myconf[@]}"
60 python_foreach_impl run_in_build_dir configuring
63 src_compile() {
64 python_foreach_impl run_in_build_dir default
67 src_install() {
68 python_foreach_impl run_in_build_dir default