remove ia64 keywords
[gentoo-zh.git] / app-admin / zenmonitor3 / zenmonitor3-2.0.0.ebuild
blob4a10e3ba6fd4b6187f673dd27d59b2c4c409d442
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit xdg
8 DESCRIPTION="Zen monitor is monitoring software for AMD Zen-based CPUs"
9 HOMEPAGE="https://git.exozy.me/a/zenmonitor3"
11 if [[ ${PV} == 9999 ]] ; then
12 EGIT_REPO_URI="https://git.exozy.me/a/zenpower3.git"
13 inherit git-r3
14 else
15 SRC_URI="https://git.exozy.me/a/zenmonitor3/archive/v${PV}.tar.gz -> ${P}.tar.gz"
16 S="${WORKDIR}/${PN}"
17 KEYWORDS="~amd64"
20 LICENSE="MIT"
21 SLOT="0"
22 IUSE="+polkit"
24 DEPEND="
25 x11-libs/gtk+:3
26 sys-kernel/zenpower3
27 polkit? ( sys-auth/polkit )
29 RDEPEND="${DEPEND}"
31 src_install() {
32 emake DESTDIR="${ED}" PREFIX=/usr install
33 sed -i "s#${ED}##" "${ED}/usr/share/applications/zenmonitor.desktop" || die
35 if use polkit; then
36 mkdir -p "${ED}/usr/share/polkit-1/actions" || die
37 emake DESTDIR="${ED}" PREFIX=/usr install-polkit
38 sed -i "s#${ED}##" "${ED}/usr/share/applications/zenmonitor-root.desktop" || die
39 sed -i "s#${ED}##" "${ED}/usr/share/polkit-1/actions/org.pkexec.zenmonitor.policy" || die
42 local DOCS=( README.md )
43 einstalldocs