1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 DESCRIPTION
="Zen monitor is monitoring software for AMD Zen-based CPUs"
9 HOMEPAGE
="https://git.exozy.me/a/zenmonitor3"
11 if [[ ${PV} == 9999 ]] ; then
12 EGIT_REPO_URI
="https://git.exozy.me/a/zenpower3.git"
15 SRC_URI
="https://git.exozy.me/a/zenmonitor3/archive/v${PV}.tar.gz -> ${P}.tar.gz"
27 polkit? ( sys-auth/polkit )
32 emake DESTDIR
="${ED}" PREFIX
=/usr
install
33 sed -i "s#${ED}##" "${ED}/usr/share/applications/zenmonitor.desktop" || die
36 mkdir
-p "${ED}/usr/share/polkit-1/actions" || die
37 emake DESTDIR
="${ED}" PREFIX
=/usr install-polkit
38 sed -i "s#${ED}##" "${ED}/usr/share/applications/zenmonitor-root.desktop" || die
39 sed -i "s#${ED}##" "${ED}/usr/share/polkit-1/actions/org.pkexec.zenmonitor.policy" || die
42 local DOCS
=( README.md
)