remove ia64 keywords
[gentoo-zh.git] / app-dicts / fcitx-pinyin-sougou-baidu / fcitx-pinyin-sougou-baidu-20241220.ebuild
blobfaaecfdc5f9ce4b332901a2e5212a6819139ae25
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 MY_PN="fcitx5-pinyin-sougou-baidu"
8 DESCRIPTION="Sougou & Baidu Pinyin dictionary for Fcitx5 and RIME"
9 HOMEPAGE="https://github.com/blackteahamburger/fcitx5-pinyin-sougou-baidu"
10 SRC_URI="
11 https://github.com/blackteahamburger/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
12 sougou? ( https://github.com/blackteahamburger/${MY_PN}/releases/download/${PV}/sougou_dict.tar.gz
13 -> sougou_dict-${PV}.tar.gz )
14 baidu? ( https://github.com/blackteahamburger/${MY_PN}/releases/download/${PV}/baidu_dict.tar.gz
15 -> baidu_dict-${PV}.tar.gz )
18 S="${WORKDIR}/${MY_PN}-${PV}"
20 LICENSE="Unlicense"
21 SLOT="5"
22 KEYWORDS="~amd64"
23 IUSE="+fcitx rime +sougou +baidu"
24 REQUIRED_USE="
25 || ( fcitx rime )
26 || ( sougou baidu )
29 RDEPEND="
30 fcitx? ( app-i18n/fcitx:5 )
31 rime? ( || ( app-i18n/ibus-rime app-i18n/fcitx-rime ) )
33 BDEPEND="
34 fcitx? ( app-i18n/libime:5 )
35 >=app-text/imewlconverter-3.1.1
38 src_unpack() {
39 default
40 use sougou && cp -r "${WORKDIR}/sougou_dict" "${S}" || die
41 use baidu && cp -r "${WORKDIR}/baidu_dict" "${S}" || die
44 src_compile() {
45 if use fcitx; then
46 use sougou && emake sougou.dict
47 use baidu && emake baidu.dict
50 if use rime; then
51 use sougou && emake sougou.dict.yaml
52 use baidu && emake baidu.dict.yaml
56 src_install() {
57 if use fcitx; then
58 use sougou && emake DESTDIR="${ED}" install_sougou_dict
59 use baidu && emake DESTDIR="${ED}" install_baidu_dict
62 if use rime; then
63 use sougou && emake DESTDIR="${ED}" install_sougou_dict_yaml
64 use baidu && emake DESTDIR="${ED}" install_baidu_dict_yaml