remove ia64 keywords
[gentoo-zh.git] / app-dicts / fcitx-pinyin-zhwiki-bin / fcitx-pinyin-zhwiki-bin-0.2.5.20241218.ebuild
blob2f1cdd3359a57e92ff3b15b8e00331a26ce00315
1 # Copyright 2022-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 MY_PN="fcitx5-pinyin-zhwiki"
7 CONVERTERV=$(ver_cut 1-3)
8 WEBSLANGV=$(ver_cut 4)
10 DESCRIPTION="Fcitx 5 Pinyin Dictionary from zh.wikipedia.org"
11 HOMEPAGE="https://github.com/felixonmars/fcitx5-pinyin-zhwiki"
12 SRC_URI="
13 fcitx? ( https://github.com/felixonmars/${MY_PN}/releases/download/${CONVERTERV}/zhwiki-${WEBSLANGV}.dict
14 -> ${P}.dict )
15 rime? ( https://github.com/felixonmars/${MY_PN}/releases/download/${CONVERTERV}/zhwiki-${WEBSLANGV}.dict.yaml
16 -> ${P}.dict.yaml )
19 S="${DISTDIR}"
21 LICENSE="Unlicense || ( CC-BY-SA-4.0 FDL-1.3 )"
22 SLOT="5"
23 KEYWORDS="~amd64 ~x86"
24 IUSE="+fcitx rime"
25 REQUIRED_USE="|| ( fcitx rime )"
27 RDEPEND="
28 fcitx? ( app-i18n/fcitx:5 )
29 rime? ( || ( app-i18n/ibus-rime app-i18n/fcitx-rime ) )
30 !app-dicts/fcitx-pinyin-zhwiki
33 src_install() {
34 if use fcitx; then
35 DICT_PATH="/usr/share/fcitx5/pinyin/dictionaries"
36 insinto "${DICT_PATH}"
37 newins "${P}.dict" zhwiki.dict
38 fperms 0644 "${DICT_PATH}/zhwiki.dict"
41 if use rime; then
42 DICT_PATH="/usr/share/rime-data"
43 insinto "${DICT_PATH}"
44 newins "${P}.dict.yaml" zhwiki.dict.yaml
45 fperms 0644 "${DICT_PATH}/zhwiki.dict.yaml"