remove ia64 keywords
[gentoo-zh.git] / app-i18n / fcitx-qt / fcitx-qt-9999.ebuild
blobf307c1c5beac64222fd3d5ce15dcc8f60fc1aea5
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake git-r3
8 EGIT_REPO_URI="https://github.com/fcitx/fcitx5-qt.git"
9 DESCRIPTION="Qt library and IM module for fcitx5"
10 HOMEPAGE="https://github.com/fcitx/fcitx5-qt"
12 LICENSE="BSD LGPL-2.1+"
13 SLOT="5"
14 IUSE="+qt5 onlyplugin staticplugin qt6 wayland"
15 REQUIRED_USE="
16 || ( qt5 qt6 )
17 staticplugin? ( onlyplugin )
20 RDEPEND="
21 !onlyplugin? (
22 >=app-i18n/fcitx-5.1.5:5
24 qt5? (
25 dev-qt/qtcore:5
26 dev-qt/qtdbus:5
27 dev-qt/qtgui:5=
28 dev-qt/qtwidgets:5
29 dev-qt/qtconcurrent:5
31 qt6? (
32 dev-qt/qtbase:6[dbus,gui,wayland?,widgets]
34 x11-libs/libX11
35 x11-libs/libxcb
36 x11-libs/libxkbcommon
38 DEPEND="${RDEPEND}"
39 BDEPEND="
40 kde-frameworks/extra-cmake-modules:0
41 virtual/pkgconfig
44 src_configure() {
45 local mycmakeargs=(
46 -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
47 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
48 -DCMAKE_BUILD_TYPE=Release
49 -DENABLE_QT4=no
50 -DENABLE_QT5=$(usex qt5)
51 -DENABLE_QT6=$(usex qt6)
52 -DENABLE_QT6_WAYLAND_WORKAROUND=$(usex wayland)
53 -DBUILD_ONLY_PLUGIN=$(usex onlyplugin)
54 -DBUILD_STATIC_PLUGIN=$(usex staticplugin)
56 cmake_src_configure