1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit cmake xdg git-r3
8 EGIT_REPO_URI
="https://github.com/fcitx/fcitx5.git"
11 DESCRIPTION
="Fcitx5 Next generation of fcitx "
12 HOMEPAGE
="https://fcitx-im.org/ https://github.com/fcitx/fcitx5"
13 SRC_URI
=" https://download.fcitx-im.org/data/en_dict-${EN_DICT_VER}.tar.gz -> fcitx-data-en_dict-${EN_DICT_VER}.tar.gz"
15 LICENSE
="LGPL-2+ Unicode-DFS-2016"
17 IUSE
="+autostart coverage doc +emoji +enchant +keyboard presage +server systemd test wayland +X"
24 RESTRICT
="!test? ( test )"
33 doc? ( app-text/doxygen )
34 enchant? ( app-text/enchant:2 )
35 emoji? ( sys-libs/zlib )
41 x11-misc/xkeyboard-config
42 x11-libs/libxkbcommon[X?,wayland?]
45 systemd? ( sys-apps/systemd )
49 dev-libs/wayland-protocols
50 dev-util/wayland-scanner
60 x11-libs/xcb-util-keysyms
62 >=x11-libs/xcb-imdkit-1.0.3:5
75 kde-frameworks/extra-cmake-modules:0
80 ln -s "${DISTDIR}/fcitx-data-en_dict-${EN_DICT_VER}.tar.gz" src/modules/spell/en_dict-${EN_DICT_VER}.tar.gz || die
86 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr
/$
(get_libdir
)"
87 -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc
"
89 -DENABLE_XDGAUTOSTART=$(usex autostart)
90 -DENABLE_SERVER=$(usex server)
91 -DENABLE_KEYBOARD=$(usex keyboard)
92 -DENABLE_TEST=$(usex test)
93 -DENABLE_COVERAGE=$(usex coverage)
94 -DENABLE_ENCHANT=$(usex enchant)
95 -DENABLE_EMOJI=$(usex emoji)
96 -DENABLE_PRESAGE=$(usex presage)
97 -DENABLE_WAYLAND=$(usex wayland)
98 -DENABLE_X11=$(usex X)
99 -DENABLE_DOC=$(usex doc)
100 -DUSE_SYSTEMD=$(usex systemd)
107 local CMAKE_SKIP_TESTS=(
118 elog "Follow the instrcutions on
:"
119 elog "https
://wiki.gentoo.org
/wiki
/Fcitx
#Using_Fcitx"
120 elog
"https://fcitx-im.org/wiki/Setup_Fcitx_5"
121 elog
"https://fcitx-im.org/wiki/Using_Fcitx_5_on_Wayland"