remove ia64 keywords
[gentoo-zh.git] / app-office / bytedance-feishu / bytedance-feishu-7.15.13-r1.ebuild
blobf26a33e365e3d18da6d46bd26447bea73e56f24d
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 inherit desktop unpacker xdg
6 DESCRIPTION="
7 飞书(Feishu)
8 飞书整合即时消息、日历、音视频会议、云文档、工作台等功能于一体,成就团队和个人,更高效、更愉悦。 "
9 HOMEPAGE="https://www.feishu.cn/download"
10 SRC_URI="
11 amd64? ( Feishu-linux_x64-${PV}.deb )
12 arm64? ( Feishu-linux_arm64-${PV}.deb )
13 mips? ( Feishu-linux_mips64el-${PV}.deb )
17 S="${WORKDIR}"
18 LICENSE="Feishu-EULA"
19 SLOT="0"
20 KEYWORDS="~amd64 ~arm64 ~mips"
21 IUSE="big-endian abi_mips_n64"
22 REQUIRED_USE="mips? ( !big-endian abi_mips_n64 )"
24 RESTRICT="strip mirror bindist fetch"
26 DEPEND="
27 app-misc/ca-certificates
28 dev-libs/nss
29 x11-libs/libX11
30 x11-libs/libxcb
31 x11-libs/libXext
32 x11-misc/xdg-utils
33 sys-apps/lshw
35 RDEPEND="${DEPEND}"
36 pkg_nofetch() {
37 einfo "Please download ${SRC_URI} at ${HOMEPAGE} "
38 einfo "and copy the .deb file into your distfiles directory"
41 src_prepare() {
42 default
43 unpacker "${S}/usr/share/man/man1/bytedance-feishu-stable.1.gz"
44 unpacker "${S}/usr/share/doc/bytedance-feishu-stable/changelog.gz"
47 src_install() {
48 insinto "/"
49 doins -r "${S}/opt/"
50 dosym -r /opt/bytedance/feishu/bytedance-feishu /usr/bin/bytedance-feishu-stable
51 domenu "${S}/usr/share/applications/bytedance-feishu.desktop"
52 doman "${S}/bytedance-feishu-stable.1"
53 dodoc "${S}/changelog"
54 local size
55 for size in 16 24 32 48 64 128 256 ; do
56 newicon -s ${size} "${S}/opt/bytedance/feishu/product_logo_${size}.png" ${PN}.png
57 done
58 newicon -s scalable "${S}/opt/bytedance/feishu/product_logo_256.svg" ${PN}.svg
60 fperms +x "/opt/bytedance/feishu/bytedance-feishu"
61 fperms +x "/opt/bytedance/feishu/feishu"
62 fperms +x "/opt/bytedance/feishu/vulcan/vulcan"
63 fperms +x "/opt/bytedance/feishu/vulcan/vulcan_crashpad_handler"