remove ia64 keywords
[gentoo-zh.git] / dev-libs / lunar-date / lunar-date-3.0.1.ebuild
bloba7394af56b86287b5646f82a89ab3f2739818665
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit meson
8 DESCRIPTION="Chinese Lunar Library"
9 HOMEPAGE="https://github.com/yetist/lunar-date"
10 SRC_URI="https://github.com/yetist/lunar-date/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="LGPL-2.1+"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="+dbus doc introspection test"
17 RESTRICT="!test? ( test )"
19 RDEPEND=">=dev-python/pygobject-2.11.5"
21 DEPEND="${RDEPEND}
22 dev-util/gdbus-codegen
23 sys-devel/gettext
24 virtual/pkgconfig
25 >=dev-util/intltool-0.35
26 doc? ( dev-util/gtk-doc )
27 introspection? ( dev-libs/gobject-introspection )"
29 DOCS="AUTHORS COPYING NEWS README.md"
31 src_configure(){
32 local emesonargs=(
33 $(meson_use dbus service)
34 $(meson_use doc docs)
35 $(meson_use introspection introspection)
36 $(meson_use test tests)
38 meson_src_configure