remove ia64 keywords
[gentoo-zh.git] / media-sound / go-musicfox / go-musicfox-4.6.0.ebuild
blobeb69dc53782f1eb90b99d0ac8b943aead294f286
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit go-module
8 DESCRIPTION="Command-line Netease Cloud Music written in Go"
9 HOMEPAGE="https://github.com/go-musicfox/go-musicfox"
10 SRC_URI="https://github.com/go-musicfox/go-musicfox/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~amd64 ~loong"
15 IUSE="clang"
17 DEPEND="
18 media-libs/flac
19 media-libs/alsa-lib
20 >=dev-lang/go-1.22.0
22 RDEPEND="${DEPEND}"
23 BDEPEND="
24 ${DEPEND}
25 || (
26 llvm-core/clang
27 sys-devel/gcc[objc]
29 clang? ( llvm-core/clang )
32 src_compile() {
33 if use clang; then
34 ego env -w "CC=clang"
35 ego env -w "CXX=clang++"
37 sed -i "s/0.0.0-\${GIT_REVISION}/v$PV/g" hack/version.sh || die
38 emake build
41 src_install() {
42 dobin bin/musicfox