remove ia64 keywords
[gentoo-zh.git] / media-video / implay / implay-1.5.1.ebuild
blob2680ac1919a424e4977cb19aa2bcf33d76cda2d1
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 CMAKE_MAKEFILE_GENERATOR="emake"
7 inherit cmake desktop xdg-utils
9 DESCRIPTION="A Cross-Platform Desktop Media Player"
10 HOMEPAGE="https://tsl0922.github.io/ImPlay"
11 SRC_URI="https://github.com/tsl0922/ImPlay/archive/refs/tags/${PV}.tar.gz -> ImPlay-continuous.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64"
16 DEPEND="
17 media-libs/freetype:2
18 media-libs/glfw
19 media-video/mpv
20 x11-libs/gtk+
23 S="${WORKDIR}/ImPlay-${PV}"
25 src_configure() {
26 CMAKE_BUILD_TYPE="Release"
27 cmake_src_configure
30 src_install() {
31 insinto "/usr/lib64"
32 doins "${BUILD_DIR}"/third_party/nativefiledialog/src/libnfd.so.1.1.0
33 dosym ../../../../../../../../usr/lib64/libnfd.so.1.1.0 /usr/lib64/libnfd.so.1
34 cmake_src_install
35 dosym ../../../../../../../../usr/bin/ImPlay /usr/bin/implay
36 make_desktop_entry ${PN} "A Cross-Platform Desktop Media Player"
39 pkg_postinst() {
40 xdg_desktop_database_update
41 xdg_icon_cache_update
44 pkg_postrm() {
45 xdg_desktop_database_update
46 xdg_icon_cache_update