remove ia64 keywords
[gentoo-zh.git] / net-dns / dog / dog-0.1.0-r1.ebuild
blob0cb99c0fd62ac0e418976a66b83963251da4e363
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.2
6 EAPI=8
8 CRATES="
9         addr2line@0.14.0
10         adler@0.2.3
11         ansi_term@0.11.0
12         ansi_term@0.12.1
13         atty@0.2.14
14         autocfg@1.0.1
15         backtrace@0.3.54
16         bitflags@1.2.1
17         byteorder@1.3.4
18         cc@1.0.61
19         cfg-if@0.1.10
20         cfg-if@1.0.0
21         core-foundation-sys@0.7.0
22         core-foundation@0.7.0
23         ctor@0.1.16
24         datetime@0.5.1
25         difference@2.0.0
26         failure@0.1.8
27         failure_derive@0.1.8
28         foreign-types-shared@0.1.1
29         foreign-types@0.3.2
30         getopts@0.2.21
31         getrandom@0.1.15
32         gimli@0.23.0
33         hermit-abi@0.1.17
34         httparse@1.3.4
35         ipconfig@0.2.2
36         itoa@0.4.6
37         json@0.12.4
38         lazy_static@1.4.0
39         libc@0.2.80
40         log@0.4.11
41         miniz_oxide@0.4.3
42         native-tls@0.2.4
43         object@0.22.0
44         openssl-probe@0.1.2
45         openssl-src@111.25.0+1.1.1t
46         openssl-sys@0.9.58
47         openssl@0.10.30
48         output_vt100@0.1.2
49         pkg-config@0.3.19
50         ppv-lite86@0.2.10
51         pretty_assertions@0.6.1
52         proc-macro2@1.0.24
53         quote@1.0.7
54         rand@0.7.3
55         rand_chacha@0.2.2
56         rand_core@0.5.1
57         rand_hc@0.2.0
58         redox_syscall@0.1.57
59         regex-syntax@0.6.21
60         regex@1.4.2
61         remove_dir_all@0.5.3
62         rustc-demangle@0.1.18
63         ryu@1.0.5
64         schannel@0.1.19
65         security-framework-sys@0.4.3
66         security-framework@0.4.4
67         serde@1.0.117
68         serde_derive@1.0.117
69         serde_json@1.0.59
70         socket2@0.3.15
71         syn@1.0.48
72         synstructure@0.12.4
73         tempfile@3.1.0
74         unicode-width@0.1.8
75         unicode-xid@0.2.1
76         vcpkg@0.2.10
77         wasi@0.9.0+wasi-snapshot-preview1
78         widestring@0.4.3
79         winapi-i686-pc-windows-gnu@0.4.0
80         winapi-x86_64-pc-windows-gnu@0.4.0
81         winapi@0.3.9
82         winreg@0.6.2
85 declare -A GIT_CRATES=(
86         [mutagen-core]='https://github.com/llogiq/mutagen;c7abc956a10e8a3e2cc71f21279ea0a42f7b7c10;mutagen-%commit%/mutagen-core'
87         [mutagen-transform]='https://github.com/llogiq/mutagen;c7abc956a10e8a3e2cc71f21279ea0a42f7b7c10;mutagen-%commit%/mutagen-transform'
88         [mutagen]='https://github.com/llogiq/mutagen;c7abc956a10e8a3e2cc71f21279ea0a42f7b7c10;mutagen-%commit%/mutagen'
91 inherit cargo
93 DESCRIPTION="A command-line DNS client"
94 HOMEPAGE="https://dns.lookup.dog/"
95 SRC_URI="
96         https://github.com/ogham/dog/archive/tags/v${PV}.tar.gz -> ${P}.tar.gz
97         https://dev.dream-universe.org/distfiles/${P}-patches.tar.gz
98         ${CARGO_CRATE_URIS}
100 S="${WORKDIR}/${PN}-tags-v${PV}"
102 LICENSE="EUPL-1.2"
103 # Dependent crate licenses
104 LICENSE+=" Apache-2.0 MIT"
105 SLOT="0"
106 KEYWORDS="~amd64"
107 PATCHES=(
108         "${WORKDIR}/patches/${P}-fix-openssl.patch"