remove ia64 keywords
[gentoo-zh.git] / net-misc / geo / geo-1.1.ebuild
blob83d6cd68b20ec8989627ce356f57d8d07939e9ba
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 inherit go-module
7 DESCRIPTION="An easy way to manage all your Geo resources"
8 HOMEPAGE="https://github.com/MetaCubeX/geo/"
9 SRC_URI="
10 https://github.com/MetaCubeX/geo/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
11 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-vendor.tar.xz
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64"
18 src_compile() {
19 ego build -trimpath -ldflags "-w -s" ./cmd/geo
22 src_install() {
23 dobin "${PN}"