remove ia64 keywords
[gentoo-zh.git] / net-misc / hoppscotch-bin / hoppscotch-bin-24.12.0.0.ebuild
blob28f9c39cc261d08e035860ab58c070c4c2053e5c
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit unpacker desktop xdg
8 DESCRIPTION="Open source API development ecosystem"
9 HOMEPAGE="https://hoppscotch.io"
10 MY_PV=$(ver_rs 3 '-')
11 SRC_URI="https://github.com/hoppscotch/releases/releases/download/v${MY_PV}/Hoppscotch_linux_x64.deb -> ${P}.deb"
13 S="${WORKDIR}"
14 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64"
19 RDEPEND="net-libs/webkit-gtk:4"
21 RESTRICT="strip mirror"
23 src_install() {
24 dobin "${S}"/usr/bin/hoppscotch
26 domenu "${S}"/usr/share/applications/hoppscotch.desktop
28 for size in 32 128; do
29 doicon -s ${size} "${S}"/usr/share/icons/hicolor/${size}x${size}/apps/hoppscotch.png
30 done
31 doicon -s 256 "${S}"/usr/share/icons/hicolor/256x256@2/apps/hoppscotch.png