1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.3
27 core-foundation-sys@0.8.7
54 pin-project-lite@0.2.15
63 rustls-native-certs@0.6.3
64 rustls-native-certs@0.7.3
67 rustls-pki-types@1.10.0
76 security-framework-sys@2.12.1
77 security-framework@2.11.1
90 timestamped-socket@0.2.6
97 tracing-attributes@0.1.28
99 tracing-subscriber@0.3.19
105 wasi@0.11.0+wasi-snapshot-preview1
106 winapi-i686-pc-windows-gnu@0.4.0
107 winapi-x86_64-pc-windows-gnu@0.4.0
111 windows-targets@0.52.6
112 windows_aarch64_gnullvm@0.52.6
113 windows_aarch64_msvc@0.52.6
114 windows_i686_gnu@0.52.6
115 windows_i686_gnullvm@0.52.6
116 windows_i686_msvc@0.52.6
117 windows_x86_64_gnu@0.52.6
118 windows_x86_64_gnullvm@0.52.6
119 windows_x86_64_msvc@0.52.6
121 zerocopy-derive@0.7.35
126 inherit cargo systemd
128 DESCRIPTION
="Full-featured implementation of NTP with NTS support"
129 HOMEPAGE
="https://github.com/pendulum-project/ntpd-rs"
132 https://github.com/pendulum-project/ntpd-rs/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
135 S
="${WORKDIR}/${P}/ntpd"
136 LICENSE
="Apache-2.0 MIT"
137 # Dependent crate licenses
139 BSD ISC MIT Unicode-3.0
140 || ( Apache-2.0 Boost-1.0 )
150 acct-group/ntpd-rs-observe
151 acct-user/ntpd-rs-observe
156 for bin
in ntp-ctl ntp-daemon ntp-metrics-exporter
; do
157 dobin ..
/$
(cargo_target_dir
)/${bin}
160 for man
in ntp-ctl
.8 ntp-daemon
.8 ntp-metrics-exporter
.8 ntp.toml
.5; do
161 doman ..
/docs
/precompiled
/man
/${man}
164 insinto $
(systemd_get_systempresetdir
)
165 doins ..
/docs
/examples
/conf
/ntpd-rs.preset
170 systemd_dounit ..
/docs
/examples
/conf
/ntpd-rs-metrics.service
171 systemd_dounit ..
/docs
/examples
/conf
/ntpd-rs.service