remove ia64 keywords
[gentoo-zh.git] / net-misc / ntpd-rs / ntpd-rs-1.4.0.ebuild
blob9a911010f4747216054bde99863389d8c7b0e7e7
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.3
6 EAPI=8
8 CRATES="
9 addr2line@0.24.2
10 adler2@2.0.0
11 aead@0.5.2
12 aes-siv@0.7.0
13 aes@0.8.4
14 arbitrary@1.4.1
15 async-trait@0.1.83
16 backtrace@0.3.74
17 base64@0.21.7
18 bitflags@2.6.0
19 block-buffer@0.10.4
20 byteorder@1.5.0
21 bytes@1.9.0
22 cc@1.2.4
23 cfg-if@1.0.0
24 cipher@0.4.4
25 clock-steering@0.2.1
26 cmac@0.7.2
27 core-foundation-sys@0.8.7
28 core-foundation@0.9.4
29 cpufeatures@0.2.16
30 crypto-common@0.1.6
31 ctr@0.9.2
32 dbl@0.3.2
33 digest@0.10.7
34 equivalent@1.0.1
35 generic-array@0.14.7
36 getrandom@0.2.15
37 gimli@0.31.1
38 hashbrown@0.15.2
39 indexmap@2.7.0
40 inout@0.1.3
41 itoa@1.0.14
42 lazy_static@1.5.0
43 libc@0.2.168
44 log@0.4.22
45 md-5@0.10.6
46 memchr@2.7.4
47 miniz_oxide@0.8.0
48 mio@1.0.3
49 nu-ansi-term@0.46.0
50 object@0.36.5
51 once_cell@1.20.2
52 openssl-probe@0.1.5
53 overload@0.1.1
54 pin-project-lite@0.2.15
55 ppv-lite86@0.2.20
56 proc-macro2@1.0.92
57 quote@1.0.37
58 rand@0.8.5
59 rand_chacha@0.3.1
60 rand_core@0.6.4
61 ring@0.17.8
62 rustc-demangle@0.1.24
63 rustls-native-certs@0.6.3
64 rustls-native-certs@0.7.3
65 rustls-pemfile@1.0.4
66 rustls-pemfile@2.2.0
67 rustls-pki-types@1.10.0
68 rustls-webpki@0.101.7
69 rustls-webpki@0.102.8
70 rustls@0.21.12
71 rustls@0.22.4
72 rustls@0.23.20
73 ryu@1.0.18
74 schannel@0.1.27
75 sct@0.7.1
76 security-framework-sys@2.12.1
77 security-framework@2.11.1
78 serde@1.0.216
79 serde_derive@1.0.216
80 serde_json@1.0.133
81 serde_spanned@0.6.8
82 serde_test@1.0.177
83 sharded-slab@0.1.7
84 shlex@1.3.0
85 socket2@0.5.8
86 spin@0.9.8
87 subtle@2.6.1
88 syn@2.0.90
89 thread_local@1.1.8
90 timestamped-socket@0.2.6
91 tokio-macros@2.4.0
92 tokio-rustls@0.26.1
93 tokio@1.42.0
94 toml@0.8.19
95 toml_datetime@0.6.8
96 toml_edit@0.22.22
97 tracing-attributes@0.1.28
98 tracing-core@0.1.33
99 tracing-subscriber@0.3.19
100 tracing@0.1.41
101 typenum@1.17.0
102 unicode-ident@1.0.14
103 untrusted@0.9.0
104 version_check@0.9.5
105 wasi@0.11.0+wasi-snapshot-preview1
106 winapi-i686-pc-windows-gnu@0.4.0
107 winapi-x86_64-pc-windows-gnu@0.4.0
108 winapi@0.3.9
109 windows-sys@0.52.0
110 windows-sys@0.59.0
111 windows-targets@0.52.6
112 windows_aarch64_gnullvm@0.52.6
113 windows_aarch64_msvc@0.52.6
114 windows_i686_gnu@0.52.6
115 windows_i686_gnullvm@0.52.6
116 windows_i686_msvc@0.52.6
117 windows_x86_64_gnu@0.52.6
118 windows_x86_64_gnullvm@0.52.6
119 windows_x86_64_msvc@0.52.6
120 winnow@0.6.20
121 zerocopy-derive@0.7.35
122 zerocopy@0.7.35
123 zeroize@1.8.1
126 inherit cargo systemd
128 DESCRIPTION="Full-featured implementation of NTP with NTS support"
129 HOMEPAGE="https://github.com/pendulum-project/ntpd-rs"
130 SRC_URI="
131 ${CARGO_CRATE_URIS}
132 https://github.com/pendulum-project/ntpd-rs/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
135 S="${WORKDIR}/${P}/ntpd"
136 LICENSE="Apache-2.0 MIT"
137 # Dependent crate licenses
138 LICENSE+="
139 BSD ISC MIT Unicode-3.0
140 || ( Apache-2.0 Boost-1.0 )
142 SLOT="0"
143 KEYWORDS="~amd64"
144 IUSE="metrics"
146 RDEPEND="
147 acct-group/ntpd-rs
148 acct-user/ntpd-rs
149 metrics? (
150 acct-group/ntpd-rs-observe
151 acct-user/ntpd-rs-observe
155 src_install(){
156 for bin in ntp-ctl ntp-daemon ntp-metrics-exporter; do
157 dobin ../$(cargo_target_dir)/${bin}
158 done
160 for man in ntp-ctl.8 ntp-daemon.8 ntp-metrics-exporter.8 ntp.toml.5; do
161 doman ../docs/precompiled/man/${man}
162 done
164 insinto $(systemd_get_systempresetdir)
165 doins ../docs/examples/conf/ntpd-rs.preset
167 insinto /etc/ntpd-rs
168 doins ../ntp.toml
170 systemd_dounit ../docs/examples/conf/ntpd-rs-metrics.service
171 systemd_dounit ../docs/examples/conf/ntpd-rs.service