remove ia64 keywords
[gentoo-zh.git] / net-proxy / juicity / juicity-0.4.3.ebuild
blob6c2e6564e141fdcf535ef6ca96af96d0346c4e02
1 # Copyright 2023-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit go-module systemd
8 DESCRIPTION="juicity is a quic-based proxy protocol."
9 HOMEPAGE="https://github.com/juicity/juicity"
10 SRC_URI="https://github.com/juicity/juicity/releases/download/v${PV}/juicity-full-src.zip -> ${P}.zip"
12 LICENSE="AGPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64"
16 IUSE="+server client"
18 S="$WORKDIR"
20 src_compile(){
21 for i in server client ;do
22 if use $i; then
23 emake "juicity-$i"
25 done
28 src_install(){
29 keepdir "/etc/${PN}"
30 insinto "/etc/${PN}"
31 for i in server client ;do
32 if use $i; then
33 dobin "juicity-$i"
34 systemd_dounit "install/juicity-$i.service"
35 doins "install/example-$i.json"
37 done