1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 DESCRIPTION
="A proxy using Chromium's network stack to camouflage traffic"
9 HOMEPAGE
="https://github.com/klzgrad/naiveproxy"
10 DIST_URI
="https://github.com/klzgrad/naiveproxy/releases/download/v${MY_PV}/naiveproxy-v${MY_PV}-linux"
12 amd64? ( ${DIST_URI}-x64.tar.xz )
13 arm? ( ${DIST_URI}-arm.tar.xz )
14 arm64? ( ${DIST_URI}-arm64.tar.xz )
16 abi_mips_o32? ( ${DIST_URI}-mipsel.tar.xz )
17 abi_mips_n64? ( ${DIST_URI}-mips64el.tar.xz )
19 riscv? ( ${DIST_URI}-riscv64.tar.xz )
20 x86? ( ${DIST_URI}-x86.tar.xz )
25 mips
) if use abi_mips_o32
; then
27 elif use abi_mips_n64
; then
30 riscv
) MY_ARCH
=riscv64
;;
34 S
="${WORKDIR}/naiveproxy-v${MY_PV}-linux-${MY_ARCH}"
38 KEYWORDS
="-* ~amd64 ~arm ~arm64 ~mips ~riscv ~x86"
39 IUSE
="abi_mips_n64 abi_mips_o32 big-endian"
40 REQUIRED_USE
="mips? ( !big-endian || ( abi_mips_n64 abi_mips_o32 ) )"
42 RDEPEND
="!net-proxy/naiveproxy"
49 insinto
/opt
/naiveproxy
50 doins config.json naive
52 fperms
+x
/opt
/naiveproxy
/naive
53 dosym
-r /opt
/naiveproxy
/naive
/usr
/bin
/naive