1 # Copyright 2022-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Auto-Generated by cargo-ebuild 0.5.4-r1
20 android_system_properties@0.1.5
31 async-compression@0.4.12
51 brotli-decompressor@4.0.1
58 c2rust-bitfields@0.19.0
59 c2rust-bitfields-derive@0.19.0
66 chacha20poly1305@0.10.1
74 concurrent-queue@2.5.0
76 constant_time_eq@0.3.1
78 core-foundation-sys@0.8.7
81 crossbeam-channel@0.5.13
82 crossbeam-epoch@0.9.18
83 crossbeam-utils@0.8.20
95 destructure_traitobject@0.2.0
102 elliptic-curve@0.13.8
111 event-listener-strategy@0.5.2
119 foreign-types-shared@0.1.1
120 form_urlencoded@1.2.1
125 futures-channel@0.3.30
127 futures-executor@0.3.30
151 hickory-resolver@0.24.1
166 iana-time-zone@0.1.61
167 iana-time-zone-haiku@0.1.2
168 icu_collections@1.5.0
170 icu_locid_transform@1.5.0
171 icu_locid_transform_data@1.5.0
173 icu_normalizer_data@1.5.0
175 icu_properties_data@1.5.0
177 icu_provider_macros@1.5.0
189 is_terminal_polyfill@1.70.1
191 jemalloc-sys@0.5.4+5.3.0-patched
201 libmimalloc-sys@0.1.39
203 linked-hash-map@0.5.6
211 lru_time_cache@0.11.11
235 openssl-src@300.3.2+3.3.2
245 parking_lot_core@0.8.6
246 parking_lot_core@0.9.10
247 percent-encoding@2.3.1
250 pest_generator@2.7.13
253 pin-project-internal@1.1.5
254 pin-project-lite@0.2.14
264 proc-macro-error@1.0.4
265 proc-macro-error-attr@1.0.4
284 regex-automata@0.1.10
295 rpmalloc-sys@0.2.3+b097fd0
297 rustc-demangle@0.1.24
303 rustls-native-certs@0.6.3
304 rustls-native-certs@0.7.3
305 rustls-native-certs@0.8.0
308 rustls-pki-types@1.8.0
309 rustls-webpki@0.101.7
310 rustls-webpki@0.102.8
317 security-framework@2.11.1
318 security-framework-sys@2.12.0
325 serde_urlencoded@0.7.1
326 serde_yaml@0.9.34+deprecated
329 shadowsocks-crypto@0.5.5
332 signal-hook-registry@1.4.2
346 stable_deref_trait@1.2.0
354 system-configuration@0.6.1
355 system-configuration-sys@0.6.0
362 thiserror-impl@1.0.63
373 tokio-native-tls@0.3.1
382 tracing-attributes@0.1.27
385 tracing-subscriber@0.3.18
393 unicode-normalization@0.1.24
396 unsafe-libyaml@0.2.11
409 wasi@0.11.0+wasi-snapshot-preview1
411 wasm-bindgen-backend@0.2.93
412 wasm-bindgen-futures@0.4.43
413 wasm-bindgen-macro@0.2.93
414 wasm-bindgen-macro-support@0.2.93
415 wasm-bindgen-shared@0.2.93
421 winapi-i686-pc-windows-gnu@0.4.0
423 winapi-x86_64-pc-windows-gnu@0.4.0
425 windows-registry@0.2.0
427 windows-service@0.7.0
428 windows-strings@0.1.0
432 windows-targets@0.48.5
433 windows-targets@0.52.6
434 windows_aarch64_gnullvm@0.48.5
435 windows_aarch64_gnullvm@0.52.6
436 windows_aarch64_msvc@0.48.5
437 windows_aarch64_msvc@0.52.6
438 windows_i686_gnu@0.48.5
439 windows_i686_gnu@0.52.6
440 windows_i686_gnullvm@0.52.6
441 windows_i686_msvc@0.48.5
442 windows_i686_msvc@0.52.6
443 windows_x86_64_gnu@0.48.5
444 windows_x86_64_gnu@0.52.6
445 windows_x86_64_gnullvm@0.48.5
446 windows_x86_64_gnullvm@0.52.6
447 windows_x86_64_msvc@0.48.5
448 windows_x86_64_msvc@0.52.6
450 wintun-bindings@0.7.7
458 zerocopy-derive@0.7.35
460 zerofrom-derive@0.1.4
463 zerovec-derive@0.10.3
466 zstd-sys@2.0.13+zstd.1.5.6
469 inherit cargo linux-info systemd
471 MY_PV
=${PV/_alpha/-alpha.}
473 DESCRIPTION
="A Rust port of shadowsocks."
474 HOMEPAGE
="https://github.com/shadowsocks/shadowsocks-rust"
475 SRC_URI
="https://github.com/shadowsocks/shadowsocks-rust/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz
478 S
="${WORKDIR}/${PN}-${MY_PV}"
482 0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 CC0-1.0
483 ISC MIT-0 MPL-2.0 Unicode-3.0 Unicode-DFS-2016 Unlicense WTFPL-2 ZLIB
486 KEYWORDS
="~amd64 ~arm64"
507 $
(usex redir local-redir
"")
508 $
(usex tun local-tun
"")
516 systemd_newunit
"${FILESDIR}/shadowsocks-rust_at.service" shadowsocks-rust@.service
517 systemd_newunit
"${FILESDIR}/shadowsocks-rust-server_at.service" shadowsocks-rust-server@.service
520 doins examples
/*.json